Setting up callcentric extension as an inbound trunk

I have a client who is the regional reseller for a specific product, as part of being the reseller they get a VOIP extension that is advertised by the product vendor. This extension comes from CallCentric and as we move them to Vital PBX from their previous PBX we have been unable to get this set up as a trunk even though it worked fine in the old PBX so we know it’s possible.

We have tried our best to use the instructions for setup found at this link but it is for version 2 of VitalPBX so not everything lines up. Does anyone have this working on version 3 that can provide us some guidance?

I recommend you use PJSIP and translate this vanilla configuration to VitalPBX GUI.

Ok did that and am pretty much at the same spot, reports shows it is registered, but the phone rings and the CallCentric voicemail ends up eventually picking up.

Are you making outbound or incoming calls? Have you analyzed the traffic using SNGREP?

Inbound, Not familiar with SNGREP but I’ll look into it.

Do the following:

Execute the command below and then place the incoming call. You should see the incoming request arriving at your PBX.

sngrep -c -r

Here’s a video about this tool.

OK here is the output, the call originated from another tennant on the same PBX so that is the first line, next one I assume is the call coming in, and the final REJECTED is probably my issue if I am reading this correctly? (I’ve fudged the IPs and Numbers)

[ ] 3582 INVITE utso101@pbx1.utsoperator.c 12355302555@pbx1.utsopera 6 CALL SETUP

[ ] 3588 INVITE 17755397555@ 7 CALL SETUP

[ ] 3606 INVITE 17755397555@sip.callcentr 12355302555@callcentric.c 3 REJECTED

Is PJSIP running on port 5060? Would you mind sharing your trunk configurations? Remember to hide any sensitive information.

Ignore the fact it is disabled, I enable it when testing and then switch it back to their old PBX as it is a live number.

The Asterisk log along with PJSIP debugging enabled will show you whats up.

My observations:

I tried these and it would no longer register at all, but I changed 1777MYCCID to 1777MYCCIDEXT on Client URI and Contact User and it now works.


I guess they explain that in their documentation:

NOTE: Any instance of 1777MYCCID should be replaced with the 1777 number assigned to you by Callcentric. EXT is the three digit extension you are trying to register this UA to.

For example, 17770001234101 would register to extension 101 on account 17770001234. However, if you are registering towards the main/default extension of your Callcentric Account (extension 100), you can simply use your 1777 number without the 3 digit extension suffix (example: 17770001234). You CANNOT register to your Callcentric Account by only using the extension number; the full 1777 number ALWAYS needs to be included.

Such a useful tool, thanks for mentioning it, I’ve never heard of it before.

Ok so this got very weird…

If we call the Callcentric number and they answer they can’t hear the caller but the caller can hear them. Of course you’re going to say it’s a NAT issue EXCEPT they can hear the caller on all other lines which are through Flowroute. So that rules out the PBX to the phones and it must be the trunk right?

BUT if we set up a test phone in our office we can hear the caller when we make a test call. So you would think that rules out the trunk to the PBX.

We are at a loss of what could cause the issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.