Calls using the URL:Tel protocol

Hi,

I would like to define VitXi WebRTC the default application to make calls via TEL protocol instead of Teams or microsip or other applications.

If i choose microsip, works:

image

MicrosoftTeams, works:

image

I edit web content and add this code to test a call to a internal extension.

image

If i choose a browser like a default app to make call via TEL protocol, doesn’t work:

image

Does have anyone a ideia how to configure this?

1 Like

This is one of the new features that will be available in the next release that will be published in the next few days.

The only thing you will need to do is to install VitXi WebRTC as a Desktop App. See the following link: Install VitXi WebRTC as Desktop App

This feature will be compatible with Chrome and Edge.

I will let you know when the new version is available,

Best regards!

3 Likes

This is already available in the Latest VitXi WebRTC update.

2 Likes

Hi @miguel

After looking for new updates, I still can’t find the option to install the new version of VitXi.

I clean cache and check online but the result remains the same.

image

System Information:

image

Some advice?

yum clean all
yum update -y

Thanks @PitzKey

Did work!

MicrosoftTeams-image (6)

image

By the way.
After install the new version, I notice that I had some problems, in the boton of logout (I can’t logout) and I can’t register my extension in webrtc, is always unregistered.

image

Does anyone had the same problems?

1 Like

Upgrade to the latest released version: 1.1.0-2

1 Like

In the add-ons module: Clean Caché => Check Online

1 Like

Thanks @maynor for the alert, but I can’t update.

Every time I use the commands:

  • yum clean all
  • yum update -y

I receive this alert even after disabling authentication in my proxy for this machine:

image

Any suggestion?

Even if I try:

  • In the add-ons module: Clean Caché => Check Online
1 Like

Check if there is a proxy or if the computer has internet.

Hi @maynor

This morning, without any changes in network or services, I had run the commands without any issues:

image
image

Now I have the version 1.1.0-3 but with the same issues.

1 Like

You could reload the app with ctrl+f5 (to clear cache), then reload the application and enter the browser console to check if there are any error messages.

When I press in the Logout button, I receive the message “WebSocket: closed”.

image

If I press in the button to update my state to registered, before or after press “Logout” button, nothing happens.

hello, try the following:

yum install yum-utils.noarch
yum install yum-complete-transaction
/usr/sbin/yum-complete-transaction
yum /usr/bin/yum clean all
yum update -y

1 Like

Hi,
It was my configuration error.
I had this configuration wrong.

image

Said NO to Enable Websocket in SIP Settings

Thanks everyone for the help.

Five stars *** * * * ***

1 Like