VitXi Mobile & VitalPBX Mobile Push Registration issue on iOS

No only 1 cell phone connecting to this account. It was working a while back but stopped working I think it was after a pbx update but not completely sure.

I deleted the app and reinstalled, it kept the account settings so I deleted the account and reconnected using the QR code FQDN. it now works but the reports show an old contacts in red, when app is off it has 2 contacts when app is on 3 contacts. but its working for now.
app open
app closed

Hi there,

we also seem to be having issues with the mobile app, on Android and iOS. as long as the app is in the foreground and open the app will wing and remain contactable on the PBX reports, but on Android, as soon as I switch apps and put VitalPBX Mobile into the background, it is no longer contactable and the push notifications do not work so calls are missed. It is a similar issue with the iOS app. The app in the foreground works perfectly, but as soon as it is in the background, it stops being contactable and the device begins getting push registration errors. I saw somewhere that this is a known issue? We are looking to replace our ageing platform with VitalPBX, all the additional features are ace! The only thing that is holding us back is the mobile app and the push notifications. I have read this forum post and tried everything mentioned and still no joy, sadly. does anyone have any other advice?

Did you do as GeryC and uninstalled and installed the App again?

Hi mo10,

I have done the same as GeryC, I have completely removed the app and reinstalled it on Android and iOS, I can test the push service on an android device by disabling the account, going to the advanced settings in that account and pushing the test push service button, and I get a Push call received OK, message. if I do the same on iOS, I get nothing back.

On iOS and Android, after locking the device or pushing the app to the background I can not receive calls, on iOS I additionally get a, failed to register with Push service message.

I have included a screenshot of my was firewall settings just in case and obfuscated my trunk’s IP

Extension config:

I do have another device attached to this extension but it is currently disconnected, therefore it is not registering:

With the mobile app in the background:

With the mobile app in the foreground:

I think I read somewhere that the app needs to de-register like this for the push notifications to behave correctly, but I don’t seem to be getting them at all.

I am running on the free community version of VitalPBX if that matters at all?



You need to set your max contacts to at least 2.
Try not to use multiple devices for now while testing.

Delete everything (extension as well) and start with everything again. Or start with a clean extension.
Uninstall the App and its data.

Try again with your additional firewall deactivated for testing.

Please check the FAQ as well:

Hi mo10,

Awesome thank you, I have now opened the firewall temporarily to the world, deleted the original extensions, and made two fresh shiny new ones.


I have removed the settings on the mobile apps and uninstalled and reinstalled the mobile apps and reconnected them with a fresh QR code generated from the FQDN. I am now seeing two registrations for each extension now, I am assuming one is the push notification server?

I now see this when the apps are in the foreground and the devices are awake:

and this when the devices are asleep or the apps are in the background:

I have made sure that is still whitelisted and it is.

I am running version 3.5.1-4 but I do not see the option to disable Push Notification, I know it used to be on the extension config page.

Is it working now?

No need to disable push in latest VitalPBX. It’s gone from now on.

Hi Mo,

Ah good, I was worried I was missing something. Unfortunately no, it is not working. I am certain I must be missing something, I am wondering if it is something to do with the environment I am testing with, it’s an AWS EC2 instance, that is using an Elastic IP for a fixed public IP, otherwise, the IP address of the server instance changes if I have it turned off for any length of time. That did initially cause me a minor challenge or two but I was able to get almost everything working, except for the push notifications. I am not averse to reinstalling VPBX as there is nothing to lose at this point, just in case it is an issue with a previous update.

Also please correct me if I am misunderstanding, is the SessionPush 1.2 meant to be Unreachable or Reachable?

I’m back with the same issue. when app is closed contacts in pbx show red and no calls, when app is open contacts show green and calls work ?

Not sure why there is 3 contacts when app is closed.

Hi GaryC,

I have the same here too, nice to know I am not alone, I am wondering if the three contacts that are unreachable, that show the IP address of the PUsh server are all failed attempts for the Push server to contact the PBX correctly?


I think if for example if you set the Max contacts to 3 for an extension, it allows up to three items to be contactable for that extension. when you open the app, one of the three contacts turns green and shows as contactable and also shows the IP of the SIP device. I wonder if every time the Push server fails to connect it creates another contact and tries again until the Max Contacts for the extension are met?

In your PJSIP Profile check that the parameters “Remove Existing” and “Rewrite Contact” are enabled.

Additionally, check if the push server IP is whitelisted in VitalPBX and any other firewall in front of VitalPBX.

“Remove Existing” and “Rewrite Contact” are enabled here. Push server IP not blocked.

I just checked again as well and can see them being RED as well most of the time. Changinge to green for a few seconds and then back to RED.

Might be an issue everybody is having with latest VitalPBX?

Hi Miguel,

Thanks for the reply, I have checked the device profile that is used by the extensions, it matches your except for the Ice support:

Also, on my AWS EC2 instance, I have already added the Push Server IP address and allowed all traffic through from its IP:

I have also tested the firewall for my EC2 instance by allowing all traffic for everything temporarily, this also made no difference, but it was a great test for the intrusion detection, it blocked 2 different attempts in the 30 mins I had the firewall in that state :smiley:

Hi, I have just been looking deeper into my issue, and with using sngrep, I have spotted MANY attempts from the Push Notification server doing the following:

Does this look right?

2022/02/25 16:13:47.655768 [Private Internal PBX IP]:5060 →
OPTIONS sip:5002@;rinstance=7C48F8B SIP/2.0
Via: SIP/2.0/UDP [Public External PBX IP]:5060;rport;branch=z9hG4bKPjcc3b5818-b247-410e-8706-3158532e64af
From: <sip:5002@[Private Internal PBX IP]>;tag=044b6c51-a506-464e-94db-8ba05df90e2e
To: sip:5002@;rinstance=7C48F8B
Contact: <sip:5002@[Public External PBX IP]:5060>
Call-ID: 33d25769-2bb9-4439-ba63-0eed616c9549
CSeq: 7133 OPTIONS
Max-Forwards: 70
User-Agent: VitalPBX
Content-Length: 0

also this:

SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP [Private Internal PBX IP]:39291;rport=39291;received=;branch=z9hG4bK-524287-1—b1e7095d09cde536
Call-ID: v8dN4_vP6NKWP0FXQkqw_Q…
From: <sip:5001@[PBX FQDN]>;tag=26f01d71
To: <sip:5001@[PBX FQDN]>;tag=z9hG4bK-524287-1—b1e7095d09cde536
WWW-Authenticate: Digest realm=“asterisk”,nonce=“1645805866/2007780f4bc57f909c7974ad5dc24ce3”,opaque=“4925e2f5168a9795”,algorithm=md5,qop=“auth”
Server: VitalPBX
Content-Length: 0

Max Contacts to 5. This happens:

image is Whitelisted.

VitalPBX has nothing to do with the mobile application issues. We have checked with SessionTalk and it turns out that the Push Server is down again.

We have notified to SessionTalk and we are waiting for them.

1 Like

Ah, thank you, Miguel, that would explain a few things.

I hate to ask, is this common? and is it monitored?

It was working fine, but it seems that has become a constant issue. We will have a serious talk with them.

1 Like