VitXi extension not registered unble to call

Hi there, I am new to VitalPBX, I manage to install Vitxi, however my extension in not registered, I tried to troubleshoot by following some post but not luck. Can someone help me in this regards. Thanks
Capture

1 Like

Hi!

Please ensure that you have followed the steps outlined in our wiki.: Introduction  – VitalPBX Wiki

Regards!

1 Like

Thanks for your reply, I had followed the guide when I setup VitXi, but yet I am facing problems. If you could suggest me any particular remedy. Thanks

1 Like

Sorry for the delayed response,

Please check if ports 6001 and 8089 are open on any active firewalls. Also, have you installed a valid SSL certificate?

Additionally, you can update to the latest version of VitXi: VitXi WebRTC 4.1.0.0 Update.

Thank for the reply, I have had ports 6001 and 8089 are open on active firewalls. and have installed a valid SSL certificate but still i get error saying connection to your server could not established and my extension shows unregistered. I have attached the screenshots. Thanks

Please run the following commands:

cd /usr/share/vitxi/

chown www-data:www-data frontend
chown www-data:www-data backend
chown -R www-data:www-data backend
chmod 755 backend
find backend -type f -exec chmod 644 {} \;
find backend -type d -exec chmod 755 {} \;

firewall-cmd --permanent --zone=public --add-port=6001/tcp
firewall-cmd --reload

cd /usr/share/vitxi/backend/
php artisan websockets:ssl-config
systemctl restart vitxi
systemctl restart vitxi-worker

Hi there, thanks for reply and suggestions, I ran all suggested commands, however it does not resolve the issue. When I ran command php artisan websockets:ssl-config it got following error: Could not open input file: artisan I don’t know what does it means?

Is that any other solution? Thanks

1 Like

Hi,

Sorry, I forgot to add a command before php artisan websockets:ssl-config.

I have edited my previous response. Could you please try again?

Please remember that it is necessary to have configured an FQDN and a valid certificate, as VitXi requires it.

Best regards,

Hi, thanks for the reply, I tried edited commands , now I do not get error of “server connection” however my extension still shows “unregistered”. also I have configured valid FQDN with valid certificate but still my vtixi extension not registered.

any other solution?

Thanks

1 Like

Hi, it is working perfectly now, I had to reset and reassign extension, it is working perfectly. I am really thankful to you for your help,

Thanks

1 Like

Perfect! I’m glad to help!