Queue agent availability status

Hello,

We upgraded to vitalpbx 3.1.4 and it looks like it broke the way queues are monitoring the device state. So as you can see below I have a queue with 2 agents logged in, I placed a call from on extension, and in the queue it shows that the extension that placed the call is not in use, and the other agent which is actually available, it shows as in use. What’s more interesting is that the issue is not consistent (and therefor hard to reproduce), sometimes it will show both agents in use, sometimes only one but the wrong one, and sometimes it will work as expected.

image

Tested with SIP and PJSIP, tested on a newly created queue with new extensions, reinstalled vitalpbx and asterisk, but nothing seems to help.

I Even tried to manually add the members to the queue from the CLI and set the state interface to directly monitor the PJSIP device, but had the same issue.

image

I do see that asterisk made some changes to the way queues are monitoring hints in version 18.8.0 the question is if that fix perhaps broke something, does anyone here have similar issues?

Thank you.

2 Likes

Nice find. Can not tell you if it happens here. Not been able to check yet.
Will “Ring Busy Agents” set to YES help a little till this is fixed?

1 Like

Thank you both! This is happening on our side too, on v3.1.4 and Ring Busy Agents set to YES does indeed seem to make a big difference.

Please see 3.1.4 R2:

Downgrade asterisk with this command:

yum downgrade asterisk asterisk-paging asterisk-dpma asterisk-core asterisk-voicemail asterisk-pjsip asterisk-doc asterisk-curl asterisk-odbc asterisk-dahdi -y
1 Like

@EINM
Can you please help here?
https://issues.asterisk.org/jira/browse/ASTERISK-29796

Thanks

Unfortunately I don’t have 3.1.4-1 and asterisk 18.8 installed, and I can’t downgrade vital / upgrade asterisk because asterisk 18.8 has been removed from vitals repo

It seems there’s a patch for this issue. The official fix will come on Asterisk 18.10.0.
https://issues.asterisk.org/jira/browse/ASTERISK-29806
https://gerrit.asterisk.org/c/asterisk/+/17723

3 Likes