Open Phones Provisioning ends in Exception

I’m on:
VitalPBX 3.1.0-1
Asterisk 18.4.0-1
Phones Provisioning 1.0.2-4

The issue:
Opening Phones Provisioning AddOn…
Admin > Add-ons > Add-ons > Phones Provisioning
…ends in the following exception:

Exception: [0-get] {https://127.0.0.1/provisioning/api/devices}: at file /usr/share/vitalpbx/www/includes/components/provisioning/RestClient.php on line 0

VitalPbxPhonesProvisioningException

Similar issue by
PBX > Provisioning > Provisioning

Any idea how to solve this?

Thanks!

Try reinstalling the provisioning add-on.

yum clean all
yum reinstall provisioning-core -y
yum reinstall vitalpbx-phones-provisioning -y

No, unfortunately that did not help.
The problem still exists.

Just as a note: “I have tested in a brand new installation, and I am not able to reproduce this issue.”

Try executing the commands below.

/usr/share/vitalpbx/scripts/apply_migrations "provisioning"
/usr/share/provisioning/artisan migrate --force

Let me know if any of these commands generate an error during its execution.

No error, I just get back…

/usr/share/vitalpbx/scripts/apply_migrations "provisioning"
/usr/share/provisioning/artisan migrate --force
Nothing to migrate.

The problem still exists.

Check the log in the following path:

/usr/share/provisioning/storage/logs/laravel.log

The logs folder is completely empty.

Well, there’s nothing else to try then.

The only other thing I can think of, is either permissions or a software version that is incompatible.

How did you install VitalPBX?

It was installed by vitalpbx-3.0.6-1.iso, around 02/2021.

Then multiple times updated by ‘yum update’ to the latest version.

It’s running as a long term test and intended for internal use for now and as soon as the API has the necessary functionality, it was planned to use it as solution for customers.

I know that the phone provisioning add-on worked in the past, at least it was possible to open it.

Since which update it doesn’t work anymore… I don’t know.

Current Linux Version: CentOS Linux release 7.9.2009 (Core)

We have the latest version working fine on several servers.

Try running:

vitalpbx check-integrity

You can also try to reboot the PBX.

This brought some errors to light…

vitalpbx check-integrity

Issues Found:
The folder or file "/var/lib/vitalpbx/static" had the group "none" instead of "apache" (fixed up)
The folder or file "/var/lib/vitalpbx/static/backup" had the group "none" instead of "apache" (fixed up)
Folder "/var/lib/vitalpbx/static/fax" didn't exist (fixed up)
The folder or file "/var/lib/vitalpbx/static/fax" had the permissions 3325 instead of 2775 (fixed up)
The folder or file "/var/lib/vitalpbx/static/fax" had the owner "root" instead of "apache" (fixed up)
The folder or file "/var/lib/vitalpbx/static/pictures" had the group "none" instead of "apache" (fixed up)
Folder "/var/lib/vitalpbx/static/recordings" didn't exist (fixed up)
The folder or file "/var/lib/vitalpbx/static/recordings" had the permissions 3325 instead of 2775 (fixed up)
The folder or file "/var/lib/vitalpbx/static/recordings" had the owner "root" instead of "apache" (fixed up)

But unfortunately this did not solve the problem.

Even a reboot did not solve the problem.

Btw:
Here is someone who obviously has the same problem, the screenshot looks suspiciously similar…

Hooray, I am not alone :slight_smile:

Anyway, I solved the problem for me by installing a new VM and by transferring the backup. On the new installation I can open the add-on.

It feels like there is a migration error in one of the past updates!?

The old VM is still running, so if anyone is interested in determining the problem - it’s still available for a while.

I also facing same provision. I found the error due to we have change the default https port to any other port will have such error.
I think is a bugs,

Have the same issue on 3.1.3 R1 … installed the addon, but no settings menu appears, and when going to the Addons menu, clicking on Phone Provisionning returns " The module provisioning doesn’t exists" …

I wonder if there are some minimum requirements needed, like having DHCP Services running, etc…
in my case VitalPBX Carrier CC is used as a Cloud PBX with multitenant, It doesn’t make sense to have Phone Provisionning settings available, but still wanted to try :slight_smile:

@SCharrua,

Did you restore a backup?

You might try reinstalling the add-on.

yum reinstall vitalpbx-phones-provisioning -y

Hi all,

Standing up a brand new VitalPBX server from the ISO file to an multi-ESX, SAN-backed cluster in our datacenter in Boston. This will replace my existing VitalPBX installation that has been sucessfully running for almost 24 months (installed 2020-01-09).

This is not my first VitalPBX installation, nor is it my first Asterisk implementation. I’ve got probably around 100 IncrediblePBX and PBX-in-a-Flash implementations under my belt. This is on an activated, registered VitalPBX Enterprise product, so I’m not trying to do any of this on the Community edition.

Obligatory VitalPBX information:

  • VitalPBX Enterprise 3.1.5-1
  • Asterisk 18.6.0-2

I ran into a problem with the Provisioning module, and it looks like I’m not alone. My error looks like this:
Screenshot 2021-12-27 105526

Following this thread, I’ve done the following, as recommended:

Random note: the metalink for epel appears to be down at the moment, so I had to disable it and re-run the above commands to get them to work.
Result: This did not resolve the issue.

Next I ran:

Result: I was told there was nothing to migrate. I rebooted the server for good measure. This did not resolve the issue.

Then I tried:

Result: No files exist in /usr/share/provisioning/storage/logs.

Then I ran

Result: It reports no issues found. Again, per the advice, I rebooted the PBX. It still did not resolve the issue.

Next, I followed this link:

Result: This post is not accepting new replies at this time.

To cover this base:

Result: I did not and have not restored from a backup. This is a fresh install. I did not want any cross-contamination from my old PBX to the new one, which means I’m migrating only what has to be from the old to the new.

Conclusion:

I’d like to get this resolved. I’m presently doing this implementation for us internally, but I have three customers waiting (im)patiently for this upgrade to their PBX’es. We’ve shown them the product and woo’ed them on it, they have signed off on the projects, but I’m not willing to deploy something that doesn’t work.

My server is your server! Need to remote in and look? Let me know and we’ll set up a remote session to jump in!

Thanks!
-Paul

Hey @anomaly0617 welcome to the community.

I may have missed it. A which point are you getting this error?

Also, worth noting, if you have the enterprise plan, you can create a ticket with VitalPBX support.

Apologies. This is under Admin (Logged in as Administrator), PBX, Provisioning, Provisioning. It happens when I try to “Add Device”. I plug in the MAC address (I’ve tried with colons, with dashes, and with no delimiters - does not matter which I do), select a Brand (Grandstream), a Phone Model (GXP2170), and a Template (Default one I created with very few settings). When I click Save, I get this error.

Got it. Can you try, for example, to map any other brand phone? My concern is that it is only happening with a specific brand (and perhaps model).

It does appear to be specific to the Grandstream line of phones. I deleted my one provisioned phone (so I had a clean environment) and created a template for a Yealink T46G. I then went to Provisioning, invented a MAC address similar to the original one (which is a Grandstream, LOL) and assigned the extension. It saved without error.

So, now the question is, how can we fix it for the Grandstream line? We have hundreds (possibly more than a thousand) in production.