Issues with Let's Encrypt & VitalPBX

I am stuck, I have changed the name of my server several times thinking it was an issue with Let’s Encrypt and perhaps a cert already in use. Any way no matter what I call my server I get the same issue when trying to get a cert for a new installation of VitalPBX, any help will be appreciated, here is the error I am getting
image
Well, I am not sure how to post a screen shot of my error in this new forum.

Here’s a topic with the same subject. The topic contains a workaround for this issue.

Unfortunately, same thing:
An exception has occurred
Exception: Invalid response header: HTTP/1.1 100 Continue HTTP/1.1 400 Bad Request Server: nginx Date: Wed, 02 Feb 2022 18:39:16 GMT Content-Type: application/problem+json Content-Length: 173 Connection: keep-alive Cache-Control: public, max-age=0, no-cache Link: ;rel=“index” Replay-Nonce: 0001mrhkXKB1v_r4qSmIBxj8tAozFLSSHiQsnZDEs28TNtQ body: { “type”: “urn:ietf:params:acme:error:badNonce”, “detail”: “JWS has an invalid anti-replay nonce: “0002HmPGIqv0409rY67PPCH6f-Rli0lbEFvMEtvVtF0d6es””, “status”: 400 } at file /usr/share/vitalpbx/www/modules/certificates/certificates.php on line 0

Error Trace

File Function

1 /usr/share/vitalpbx/www/index.php:0 app\Core->run(…args);
2 /usr/share/vitalpbx/www/includes/app/Core.php:0 app\Core->_loadModule(…args);
3 /usr/share/vitalpbx/www/includes/app/Core.php:0 app\Core->loadModuleAction(…args);
4 /usr/share/vitalpbx/www/includes/app/Core.php:0 modules\certificates\certificates->put(…args);

I had the same issue and it ended up being the internet provider blocking port 80.

Thanks, I will double check that.

I had the same issue after many months of working fine, no changes to firewall or ISP changes only Vitalpbx updates, I followed the fix mentioned above and all is working again.

Unfortunately it didn’t work for me but thanks for your response and help.

Did you try this?

This is what I am getting from the log:
[2022-02-07 13:42:51.077625] [debug] HEAD response received
request: ‘HEAD https://acme-v02.api.letsencrypt.org/acme/new-nonce
header: 'HTTP/1.1 200 OK
Server: nginx
Date: Mon, 07 Feb 2022 18:42:50 GMT
Connection: keep-alive
Cache-Control: public, max-age=0, no-cache
Link: https://acme-v02.api.letsencrypt.org/directory;rel=“index”
Replay-Nonce: 0002e4RDCg8B40jqqcalXojYFVvSlLUjSlbcF8Pit5BantU
X-Frame-Options: DENY
Strict-Transport-Security: max-age=604800

'
status: 200
body: ''

[2022-02-07 13:42:51.084491] [info] No account found, attempting to create account.

Then I get:

image
After that appears on the screen I go back to the log and I see:

[2022-02-07 13:45:01.485877] [debug] POST response received
request: ‘POST https://acme-v02.api.letsencrypt.org/acme/new-acct
header: 'HTTP/1.1 100 Continue

HTTP/1.1 400 Bad Request
Server: nginx
Date: Mon, 07 Feb 2022 18:45:00 GMT
Content-Type: application/problem+json
Content-Length: 173
Connection: keep-alive
Cache-Control: public, max-age=0, no-cache
Link: <https://acme-v02.api.letsencrypt.org/directory>;rel="index"
Replay-Nonce: 0001FKXIVkif3440RAUOAsNUZI0uBO5-q17wK1Zw7n_Ehtc

'
status: 400
body: array(
    'type' => 'urn:ietf:params:acme:error:badNonce',
    'detail' => 'JWS has an invalid anti-replay nonce: "0002e4RDCg8B40jqqcalXojYFVvSlLUjSlbcF8Pit5BantU"',
    'status' => 400,
)

[2022-02-07 13:45:01.488975] [error] Invalid response
url: ‘https://acme-v02.api.letsencrypt.org/acme/new-acct
method: ‘POST’
status: 400
header: 'HTTP/1.1 100 Continue

HTTP/1.1 400 Bad Request
Server: nginx
Date: Mon, 07 Feb 2022 18:45:00 GMT
Content-Type: application/problem+json
Content-Length: 173
Connection: keep-alive
Cache-Control: public, max-age=0, no-cache
Link: <https://acme-v02.api.letsencrypt.org/directory>;rel="index"
Replay-Nonce: 0001FKXIVkif3440RAUOAsNUZI0uBO5-q17wK1Zw7n_Ehtc

'
body: '{
    "type": "urn:ietf:params:acme:error:badNonce",
    "detail": "JWS has an invalid anti-replay nonce: \"0002e4RDCg8B40jqqcalXojYFVvSlLUjSlbcF8Pit5BantU\"",

…and of course none of it makes any sense to me, oh BTW, I turned off the firewall before attempting to do this as suggested by a previous poster just so I didn’t have anything firewall-wise causing issues.

Can you use a wildcard.domain.com cert with VitalPBX?