Configuration help with voiptalk.org

Hi guys,

I am currently running FusionPBX with voiptalk.org as our SIP trunk provider.

I am looking to migrate to VitalPBX but i don’t seem to be able to get things up and running. Does anyone have a guide or something that may help with setting up with voiptalk.org?

Cheers
MS

Hi Matthew and welcome to the forums!

I’m not familiar with that particular vendor. But do you know if they allow IP auth? If so then it should be very easy.

Hello Matthew I am attaching you an example of a trunk with voiptalk.
voiptalkconfig
voiptalk2config

Hi @PitzKey I do not believe they support this :frowning:

Hi @ddavila

Yes i saw this, and configured it as so.

I am seeing this
Untitled

Ok to update things.

Outbound calls are now working, but nothing at all incoming. Nothing showing in the logs when calls made to the number in question.

More messing i guess :slight_smile:

Use sngrep to check if the INVITE even hits your server.

You can post the raw packets here

Hi @MasterShifu,

If you are using the latest version of VitalPBX, keep in mind that by default, PJSIP UDP runs over port 5060, and SIP UDP runs over port 5062. So, if you have created a SIP Trunk, and your provider is sending the call over port 5060, it will never reach the trunk because, as I mentioned, SIP runs over port 5062.

Now, you have two options:

  1. Create the trunk using PJSIP instead of SIP (recommended).
  2. If your provider allows you, you can modify the origination SIP URI to something like “sip:YOUR_PBX_IP:5062.”
1 Like

Hi @miguel

thanks for your suggestion, i setup a PJSIP trunk, and can make outgoing calls, but when making a call from an external number ( which i expect to come to my inbound route ), it does not hit my PBX at all.

Not sure what i have done wrong, when calling the number i get the auto responder from my provider saying no user available. Seems it is aware it can not send to my PBX so auto responds on my behalf.

Any idea what i can do now?

It is the inbound i need to fix :frowning:

Heh @PitzKey I checked sngrep, i can see my outbound calls showing ( which works ) but absolutely nothing showing when making an inbound call from an external number ( landline or mobile ).

Check the PBX firewall if there’s a banned IP. Also, if your PBX is behind NAT make sure that the NAT router isn’t blocking the traffic. Finally, make sure that the config on the carrier side is correct.

@MasterShifu,

Maybe you are missing some configuration in the VoIP provider portal.

For example, in the case of Twilio, you have to configure the Origination SIP URI to receive calls.
image

Yeah, checked IP Tables, nothing there, nothing fail2ban has banned. External firewall is not blocking anything related to this. the config carrier side, is as it has been for years, nothing has changed.

Like i say it works with FusionPBX just fine. But i really really wanted to make the switch.

I’m stumped.

I have checked and am doing as they say, i can route to FusionPBX just fine.

So i am obviously doing something wrong with Vital.

Here is the guidance you get from voiptalk …

Processing: Screenshot 2022-01-13 at 01.42.43.png…

It seems that the screenshot didn’t get attached.

Did you check in the GUI? I don’t know what blocking tool VitalPBX uses on their latest version.

There are definitely stuff that needs to be changed. Such as pointing the DIDs to the new Trunk etc.

Can your carrier provide you with the SIP packet capture after a failed call? Most popular carriers have these captures available in the Portal.

Screenshot 2022-01-13 at 01.42.43

Here we go :slight_smile:

Try with the following configuration. It seems your provider required registration for incoming calls.

image

Haha! Getting somewhere now!

Only trouble is, callers cannot hear me :frowning: and the call dies at 20 seconds.

I am behind an OPNSENSE firewall, have created port forward rules and allowed them to pass through, not sure what i can do now.

But at least a step in the right direction.

Where’s your PBX hosted?

Did you configure the Signal and Media address on the PJSIP Settings?