Boot stuck to "Wait, We are processing some stuff"

Hi,

After latest upgrade my vitalpbx WebGUI is stuck. On the screen there is only eternal announcement:
SomeStuff

Console connection seems to work fine. I am able to see from sngrep that the system is alive but not working well. After searching for the problem I found out that it seems that mariadb has collapsed.
MariaDBError

How can I fix this problem?
The first option is to fix this without doing major installation procedure. How?
The second option is to reinstall the whole vitalpbx, but to do that I need to either find if there are automatic backups/where or how to do the backup with console.

I have tried with 4 different computers (IP) and in every computer same error.

VitalPBX is installed at the moment in Qnap as separate virtual machine which has been working fine for years until this latest upgrade.

Thank you for your assistance.

Check this post "Wait, We are processing some stuff!" - #11 by hlev

I already did and it is about ip ban. My IPs were not banned. And the solution suggestion says that it is related to mariadb not running. As you can see from the screenshot of console session mariadb is down.

Fail2ban

My question is how to recover from mariadb crash. My system has been running like 2-3 years with this setup since early v2 without any problems. Now with the latest upgrade database have crashed or something has happened that crash the connection.

How to recover? If I need to reinstall I need to backup everything from the old one. If I can recover from crash without reinstall it would be great. How?

Did you try a simple reboot?

After some intensive searching I was able to find out what was the problem and fix it.

Finally after all kinds of bug hunting in console with command df -h I found out that drive vda3 is full. After some searching I finally realized that the problem was that during the original setup I had created my own log file for checking that everything works and during the time it had filled the whole drive. 10GB of log garbage in /var/log/asterisk. Zero space left.

That is why mariadb did not start because of no space left in drive and that is why the whole system was not operating well. Could not even log into webGUI.

For VitalPBX development I suggest that if drive is full there would be some hints about drive space. Only eternal “wait, we are processing of some stuff” is not very intuitive when one needs to get the system running asap.

There is even a function in the Webgui to receive an email when there is only xx % space left. This would have helped you i guess.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.