Yealink phones - 488 Not Acceptable Here

Hi everyone!

I am new to VitalPBX and voip overall. We use VitalPBX version 3.1.0-1.

We use 3 different kind of phones:
Yealink T43U
Yealink T31P
Htek UC842

After creating the PJSIP extensions in VitalPBX we configured them in the phones. They are Registered.
The problem is that the Yealink phones can’t recieve any incoming call and go directly to voicemail. They don’t even ring out. Internal calls do not work also.
The only thing that works with them is i can call an external mobile number and talk to them (works fine 2 way audio).

I have already tried to debug the issue i have the packet capture from the phone. After opening it with wireshark i can see that it says the error “488 Not Acceptable Here”.
I have already googled this error message and found out it is something to do with Codecs and or Secure connections.
I have checked the codecs in the phone and configured the same ones on the phone and the extension even in the Default PJSIP profile.
SRTP is disabled on the phones and as far as i can tell there is no option to disable it in the PJSIP settings.

The Htek phone works like a charm after setting up the account and registering.

What did i miss? Can you help me with this issue?

Thanks in advance!

You are calling a from a phone that supports video calls to a phone that does not.

You can:

  1. Set that the default call should be voice, not video.
  2. On the extension of the phone that does not support video remove all codecs and add only audio codecs that the phone supports.

Thank you for your reply.

I’m not sure where i can set the default call type, i’ve checked everywhere in vitalPBX.
I’ve changed the codecs to voice only codecs that are supported by both phones.

The Default PJSIP Profile is set up like this:
image
All of the related extensions are set up like this, everything is on default pretty much except the codecs:
image

I’m still getting the “488 Not Acceptable Here” error when i try an incoming call. No ringing either.

You do that on the phone, not the PBX.

For testing purposes disable video on the PBX.

Thank you for the reply!

I’ve contacted Yealink support and they have said that these phones doesnt have a video codec nor they have other video settings. From the packet capture i’ve sent to them they have said that it is normal from the phones side and the “488 Not acceptable here” is sent from the server.

Currently all codecs are disabled on the phone and the extensions except G722. The problem still persists.

They have suggested changing to TLS transport and a different port, which i did according to my server’s settings. The phones register but become unreachable on the server side. I am not sure why.

What else can i try to make them work?

Thanks in advace!

What happens when you try and dial voice mail, do you get the prompt? Try changing the codec to g711a and see if that helps. Do so on the PBX as well as another internal extension and see if you can then make a call to each other.

Did you try disabling video?

Thank you for the replies!

I have changed to codec settings on the phones and the extensions to G711.

When i call one phone from another the other phone doesnt ring out and i get directed to voicemail. I get a prompt, i can even listen back to the voicemail i left from the extension’s portal.

I can do the same if i call from an external mobile number but then i can not see the voicemail i left in the portal of the extension.

I can’t disable video on the phones because they dont even support it. On the PBX the only option i found about video calls is on the “Default PJSIP Profile” the Direct Media option was already disabled and i changed the Max Video Streams from 5 to 0. Is there an option besides this one?

image

In the asterisk console run:

pjsip set logger on

Reproduce the issue, upload the output to pastebin.com (be sure to stop the console as soonas you are done with the call, otherwise there will be a ton of non-needed information)

Post the pastebin link here.

Thank you for your reply!

I have run the command, the console says that the logging is turned on, but when i reproduce the issue the output of the console stays blank. It doesnt matter which way or if its from internal or not. There is no logging even if i call an external number, which works.

These phones are separated to one of my tenants, I’ve tried the CLI on my tenant and on “PBX Main” as well. After enabling the logging i went to the “Log file viewer” and copied the last 500 lines from “full”
I can see lines including these “res_pjsip_logger.c: <— Received SIP response” so maybe here is where the output goes.
Pastebin: Log - Pastebin.com

image

Thanks. It seems like you have configured TLS/SRTP and the phone does not like it.

Thank you very much!

Sadly i wasn’t the one who configured the server initialy, but i’ve tried to disable every TLS related setting i could find.

We use a SIP trunk and PJSIP extensions.
I’ve checked the trunk and i did not see anything related to TLS or SRTP only the Profile which is set to “Default SIP Profile”.
I went to the device profiles and the technology settings and disabled anything related to TLS.

I’ve checked the online documentation and a video about TLS and SRTP and i am still getting the “488 not acceptable here” error.

Could you tell me what did i miss?

Névtelen
Névtelen 2
Névtelen 3
Névtelen 4

Disable WebRTC and AVPF
You can’t have regular endpoints and WebRTC in the same profile.

1 Like

Thank you very much PitzKey! That solved the issue. :grin:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.