VPBX4 - PJSIP inbound calls rejected - SOLVED

As my VitalPBX server v3 was near EOL and I have built a new server from scratch with VitalPBX v4

The extensions/trunks are now PJSIP

I have two DIDs, each with a diffferent voice provider. Each DID has a trunk and an inbound route.
Settings for the trunks and inbound routes are basically the same they were on the V3 server.

Outbound calls are working.

But on the new v4 server incoming calls don’t work for one of the DIDs, but work OK for the other.

sngrep shows the INVITE for the problem DID says “401 - unauthorised”
and shows this (numb=ers masked with xxxxxxxx & yyyyyyyy):

2024/05/26 17:28:16.877076 103.93.68.24:5060 → 192.168.8.70:5060
INVITE sip:612xxxxxxxx@192.168.8.70:5060;line=pmfolqg SIP/2.0
Via: SIP/2.0/UDP 103.93.68.24:5060;rport;branch=z9hG4bKPjbfc2a4a4-1d5f-426f-8eb1-9f1c7c27f01f
From: “04zzzzzzzz” sip:04zzzzzzzz@103.93.68.24;tag=58b41997-95b2-421f-9020-16245a22c174
To: sip:612xxxxxxxx@192.168.8.70:5060;line=pmfolqg
Contact: sip:asterisk@103.93.68.24:5060
Call-ID: 2de81781-a72a-4c53-b612-3848835dc3a8
CSeq: 2394 INVITE
Allow: OPTIONS, REGISTER, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL, UPDATE, PRACK, MESSAGE, REFER
Supported: 100rel, timer, replaces, norefersub, histinfo
Session-Expires: 1800
Min-SE: 90
Max-Forwards: 70
User-Agent: Siptalk PBX
Content-Type: application/sdp
Content-Length: 435

Is there some advice you can give?

Wow. They are using Asterisk for their SBCs? Interesting.

Anyway, you’d need to share your Trunk settings and a call trace with PJSIP logging enabled.

Please use pastebin to share the call trace

Issue has been resolved. I had put a sip password in the Trunk field called “Local Secret”. This was forcing VPBX to try to authenticate to the sip server for inbound calls. Removing that password resolved the issue.

1 Like