Voicemail with custom announcement

We have created a special mailbox with Technology=None that shall used as a central ring group terminating destination in case no one answers an incoming call.

This works well, including the internal announcements “Please leave your message after the tone…”, but we don’t want these internal prompts because we have our own custom announcement that should be played instead for this extension.

When we do this, our custom announcement is played correctly, but after our message the standard prompts are played, so the caller gets two consecutive instructions on how to leave a message.

I am unable to find a way to suppress these internal voicemail promps. The most logical way would be to have a “VoiceMail Without Prompt” selection as a substitute for the “VoiceMail Diect” extension that we currently use.

Please note: we don’t want to replace any general Asterisk prompts, we just want a single VoiceMail extension that has the internal prompts suppressed.

In VItalPBX 3 this was possible (even though I can’t remember exactly how we did it), but how can this be done in VitalPBX 4?

You even mentioned the solution: “VoiceMail Diect”

Use the announcement and then use voicemail direct as destination.

And maybe this also needed:

As @mo10 mentions in his reply, the SKIP INSTRUCTIONS toggle in the extension voicemail section is what controls the default message, toggling that allows you to setup an announcement before and use VOICEMAIL DIRECT in your call flow. You can also manage the announcements directly in the BUSY or UNAVAILABLE PROMPTS and just withing your call target to Voicemail Busy or UNAVAILABLE if you prefer.

mo10, I am exiting my Announcement into Voicmail Direct Extension 100 and the “Skip Instructions” button is activated. However, the caller still gets the message “The person at extension 100 is on the phone - beep”.

Any idea how this message can be disabled for this voicemail extension?

Send screenshots just like I did please. Announcement Module as well.

Is in the phone sounds like busy.

Here you go:

Please check the screenshot again which i shared!

Oh boy, that was inadvertedly set to Extension AB instead of Voicemail AB.

I was so sure that I had set it to Voicemail Direct originally that never re-checked it.

Ashes on my head, and thank you for your patience. This community is fantastic!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.