Vitxi showing Error message while all seams good

Hello team
We are seeing an Error message while connectin extensions to Vitxi.
Extension are correctly registered and we tried calls, they work fine, how ever, the bellow message stills is visible

Best regards

Hi Gentil Map,

This usually indicates that the connection to the websocket is not setup correctly or is not possible.

Can you please confirm that the certificate is valid and you can access the WS port?

Hello @PitzKey

Thanks for quick Answer.
The Web socket seams ok as the bellow link is showing something:

Best regards

Looks like your SSL certificate was updated today, a couple of hours ago


If you have done this manually, please make sure you set this new certificate everywhere and reload asterisk. You can try to reload with

vitalpbx fully-dump-conf
asterisk -x"core reload"

Thanks for your replay
The command bellow didnt work

vitalpbx fully-dump-conf

The available commands are:

        reset-pwd [username]

Which one do we use?


Yeah, looks like these commands were changed in v4.


vitalpbx fully-gen-conf
vitalpbx gen-conf
1 Like



But message still there.


for the Cert, our PBX is on a subdomain, so on “Domain” i provided same value as for “sub-domain”, is it correct?

Best regards

If you can, maybe try a apache and Asterisk restart. A full reboot will kill both birds in one shot.


I have rebooted.
While rebooting, on VitXi i saw this (this is normal):


After rebooting:

Extension registered but message still there

I am afraid that the websocket, for some reason, is still using the old cert. I think @maynor may be able to guide you further

1 Like

i have checked and seams like the PBX is using a different Certificate than Vitxi

VitXi modified in January


VitalPBX, modified today


How is it possible?

1 Like


Please, create a new certificate, and in the “hostname” field set: And in the subdomain field set

Then select the certificate in the “Mini Http Server” module. Also in the device profiles module (Settings > Technology settings > Devices profiles) select the webrtc profile that your VitXi extensions are using and in the DTLS Certificate field select the certificate you just created:

Apply changes and reload the application,

Let us know if it worked for you,

Best regards!

1 Like

Hello dear @maynor

We followed these steps but no chance!

We deleted all Certs and restarted from 0, but then, extensions are registered but that message stills there

Best regards

1 Like

Hello Sir!

Could you please check in the PJSIP Settings if the certificate is selected?


HEllo dear

At this place it wasnt, i just selected it, let me try again

Best regards

1 Like

hello dear @maynor

I was able to fix the issue by reinstalling VitXi!

Message is nolonger there!

Just last thing, after reinstalling, one Tenant is not able to see the list of his extensions.

From admin side, i can see his extensions when i select the tenant’s name.

When we connect on the Tenant’s account, we can see the list at right but when we select an extension and want to update it, we have the error message

The assigned device, 7002, has not been found on the PBX or is not available.

While the extensions is available on PBX

Bellow is the PBX view

Best regards

1 Like

Which version of VitXi do you have installed?

Hello dear
This one


1 Like

We will fix this issue as soon as possible,

Thank you for reporting this issue,

Hello dear @maynor

What do you suggest us to do meanwhile as we are in production ? Go back to V3 ?

Best regards