VitXI Loading slowly and Memory USage

Hello dear team

We note from this morning that our service is not working fine

  1. Vitxi: This application is not loading correctly, it takes long time and doesnt allow us to work
  2. We note also the Memory Usage is showing 100% used


We have 3 Tenants (2 actives)

  • The first Tenant mostly using VitXI and has 30+ active extensions (he does 100+ calls per day)
  • The second uses mostly Desk phones and Vital COnnect app
    Please help


Just to be clear we never used VitXI.

You say one tenant mainly using VitXI? Slow as in the application is slow? Tenants are I assume on separate networks? If you are on a separate network, maybe you fire up a VitXI instance and see if it’s slow to eliminate network?

looking at your resources, I don’t think its standard memory / CPU usage on your machine.

1 Like

Hello dear,

I was talking about VitXi WebRTC

Our client who has agents located in Morocco, Togo, Benin, all are not able to load VitXi correctly.

The bellow URL is still loading continuesly: webrtc app


When I web browse to that URL it gives me a login screen, is that the PBX (VitXi front end?) I assume. Does it load continuously after logging in? Are you getting the same as the clients?

How do we fire up new instance please?

Yes, when you put login and password of user, it loads continuesly

Sorry, I am thinking local softphone, this is a web service on your PBX. So if you login, assuming you are not on the same network as your customers, does it too load continuously for you?

Yes, Vitxi and VitalPBX are installed on same server and it’s Cloud Based

Assume deskphones are not getting audio issues etc? Have you checked latency from your server?

1 Like

VitXI looks like it runs as a separate process, maybe there is a way to restart that process? If no other functionality is being effected, someone might know how to do that?

1 Like


Wtually i was using Mozzila Firefox.
When i try to connect using an other browser:

  1. Chrome : Correctly connected without slow loading


  1. Mozzila Firefox: Still loading

Just installed on my test server, can confirm the same.

1 Like

As all the Addons + VitalPBX are on the same server, earlier this morning i Upgrade Debian, rebooted, checked new update, etc

Actually, as for my previous comment, service seams working bad on my FireFox and works fine in others browsers, i asked clients located in others countries to test and share feedback
I’ll let yiu know

Tried it on Firefox and I get:

Firefox can’t establish a connection to the server at wss://:8089/ws.

Looks like FF is having problems with connecting to the websocket. Why I don’t know.

1 Like

We continue testing all possibilities and will post here any update

after testing further, we note that service is not stable, some agents tried to use multiple Browsers and having issue.

The latest one got:

He is using the Desktop application but also Chrome

I removed cache on Firefox for the our test system and it loaded for a while until it dropped again.

1 Like


Please verify that port 6001 is enabled in VitalPBX and in any Firewall you have active.

Then, run the following commands:

vitalpbx apply-firewall

/usr/share/vitxi/backend/artisan websockets:ssl-config

systemctl restart vitxi

After that, please reload the application by pressing Ctrl + F5 (perform a hard reload to clear the browser cache).

Please let me know if it worked.


I think it’s the only place we could have that port as we didnt change anything so far, yesterday it was working fine.

Sorry dear, i didnt understand how to use this

Done it but didnt change anything

You need to copy and paste the following command in the server terminal. This command configures the VitXi service. After executing this command, run: systemctl restart vitxi.

Then, reload the application by pressing Ctrl + F5 (perform a hard reload to clear the browser cache).