Vitxi can't connect to wss

I can’t seem to use my Vitxi installation anymore. It was working, up until a recent update.

I keep getting the console error “can’t establish a connection to the server at wss://REDACTED:6001/app/vitxi4561aq/console.”

I’m connecting via LAN, so no third party firewall is between me and the server. It’s installed alongside VItalPBX, not on a different server.

Any help is appreciated. Thanks.

1 Like


Please verify that port 6001 is enabled in VitalPBX and in any Firewall you have active.

Then, run the following commands:

vitalpbx apply-firewall

/usr/share/vitxi/backend/artisan websockets:ssl-config

systemctl restart vitxi

After that, please reload the application by pressing Ctrl + F5 (perform a hard reload to clear the browser cache).

Please let me know if it worked.


No luck, same error message. I did get the following error after running the ssl-config command you gave me.

Error: no se pudo encontrar la ruta del archivo de certificado SSL CA en el archivo de configuración de Apache.

Do you have a Let’s Encrypt SSL certificate configured, or do you have a custom certificate?

If you have a custom certificate, could you please check in the “Certificates” module of VitalPBX if the “chain” field has a value? If it doesn’t, you can set the content of the chain file provided by the certificate issuer in this field. Alternatively, you can copy the content from the “Certificate” field to the “chain” field.

After that, please try running the commands I provided again.

1 Like

That was the trick! I have a custom SSL cert, and didn’t fill in the chain when I initially set it up. Seems to be working now. Thanks!


I’m glad to help!! :)))