VitalPBX Early media support

Hello,

I am unable to configure the “early media” support on a PJSIP SIP trunk or device profile (in some cases, this setting is also named premature media).

Example: If a mobile phone is in flight mode or turned off and a call is made from VitalPBX, the call keeps ringing as if the mobile phone isn’t answering.
The response should be unavailable, this was tested from other PBXs and works properly.

Please help in resolving this issue.

Best regards, Klemen

Try disabling the ringing tone from the Dial Profile. You can create a new Dial Profile for your trunk if you need it.

image

Early Media in asterisk is to transmit one way audio, not necessarily related to the type of ringtone.

From what I understand, it looks like the device is responding with a ringing 180.

A logfile with SIP debugging enabled will tell you whats happening

Thank you for the prompt responses.

I have disabled the ringing tone in the dial profile which is used and the result is the same.
Please find the log file in the attachment, is this log appropriate or do you require any other type?
The call was made from extension PJSIP/11266.
11266_trace.txt (30.7 KB)

Best regards, Klemen

I only see a regular Dial in your log; nothing unusual.

In this case the behavior of the PBX depends on the response returned by your VoIP provider. You can use the SNGREP tool to see the responses or events returned by your VoIP provider.

Please find the screenshot of the sngrep attached. Where can I send You the complete file?
IP .10 is VitalPBX
IP .09 is SBC
IP .02 is router (call was made from a softphone with an established VPN). The same occurs with calls from devices in LAN.
SNGREP 11266

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.