We have install VitalPBX 4 HA (running on Hyper-V) – No problem, so far everything is working. We try the Bascul command and no problem as well.

We proceed to install the add-ons SONATA Recording, SONATA Stats, SONATA Switchboard on both vm. When I try to configure SONATA Recording we setup the username and password (no problem) but when we try login it says that “user/password incorrect”

And for the SONATA Stats, we get the initial setup screen to configure the database, we click next and we get the failed to establish connection.

1 Like

Here a log from the sonata stats
stats-root-2023-03-25.txt (1.5 MB)

I think I have solve the problem the SONATA Recording. In the initial setup, i though that name you setup it was the user, i try with admin and the password I setup and no problem.

But still have the problem with the SONATA Stats

1 Like

Has anyone has seen this?

1 Like

Hello Sir!

Are you getting the same issue on both servers?



Yes, we are getting the same issue on both server. We try on our test environment and also on the client environment.

Any comments? Anything that I can do ?

Unfortunately, we haven’t thoroughly tested the add-ons on the HA environment.

IMHO, I do not recommend implementing HA until we get something more reliable.

Just wondering if there any updates regarding the SONATA Stats add-on on an HA system?

Did you install Sonata Stats on both Servers?
It is always recommended to install everything first on both Servers separately and lastly run the Script for the HA.

There is a command to eliminate the HA without affecting the information of the Servers.
./ destroy
Install the Add-ons on both servers and then run the Script again on Server 1

Like you mention I did install the Sonata Stats, Recording, Swichboard before running the script, but only stats gave the problem.

I did what you recommendedm, but I saw something interesting

  • I ran the ./ destroy I did complete the process but when I check server 2, it has the floating ip and reports as the master.
  • at this point I al try to uninstall stats add-on from both server and then install it on both server again.
  • I ran the ./ rebuild on server 1 at the end I gave me an error, so I ran it for a second time adn this time works. Server-1 is master and server-2 is slave. Everything seems to be running normal.

Sonata-stats remains with the same problem, but also the issue when I ran the ./ destroy

We detected an Issue with access to mariadb, since it only allowed the server’s ip and not the localhost. This Issue was already corrected in the Script. However, if you want to correct it on your servers directly, we recommend editing the file:
/etc/mysql/mariadb.conf.d/50-server.cnf and configure bin-addres as follows on both servers.
bind-address =

After restart mariadb
systemctl restart mariadb

I have download the scripts again.

I ran ./ destroy and it looks like it works just fine. I did procedure of unintalling sonata stats from both server and install it again.

I ran ./ at the end it gave me communication error. It did not gave me before I download again the script. I also try ./ rebuild but same result.

When there are authentication problems, it is because the firewall took some inappropriate temporary configuration. We recommend to reboot from both servers and try again.

1 Like

Thanks. After rebooting the server the script ran without any problema. And the sonata stats is working now, after installing the add-on before running the script.