V4: postfix smtp error

Got this Error:
SMTPS wrappermode (TCP port 465) requires setting “smtp_tls_wrappermode = yes”, and “smtp_tls_security_level = encrypt” (or stronger)

so i put with nano /etc/postfix/main.cf

smtp_tls_security_level = encrypt
smtp_tls_wrappermode = yes


service postfix restart

And Emails worked fine.

Can you please add this as a checkmark in the gui?

Or how to persistetly save or add to the main.cf?
Maybe we can have a custom textfield for that?


The custom parameters in the postfix file aren’t remove or overwrite.

If that parameter is overwritten is because is part of the settings in the VitalPBX module.

Its not right what you are saying.
Please test it yourself.

Add those lines onto the last line in main.cf:

smtp_tls_security_level = encrypt
smtp_tls_wrappermode = yes

BOTH will be gone after you hit save in the guy.
But only this is part of your main.cf:


Please tell me how changes in the Gui will keep my 2 lines:
smtp_tls_security_level = encrypt
smtp_tls_wrappermode = yes


If those parameters are overwritten is because they are part of the settings in the VitalPBX module(In the GUI or under the hood).

Idea how to fix this?
Can you add a custom text box and attach those values of user wants, please?


Hello, I am new to this, and I am having problems setting up E-mail SMTP (Using either Gmail or any other like hotmail) postfix get into a kind of loop (on queue). and a lot of errors. I had to flush/ stop the queue. Any help setting up this? Please advise.
Thank you

My question again:
can you please add a textfield which will add our lines to the end of the main.cf?

This way everybody should be flexible. Thanks