Unable To Upload Call Recordings

Hello. I upgraded from 3 to 4 yesterday, however it looks like my backup was larger than the space available on the old server. New server has double the space. I downloaded the call recordings prior to the migration and was just going to copy them over but I am running into some permissions issues…

When I try to upload these with Filezilla to the /var/spool/asterisk/monitor directory they fail with a “permission denied” error. Tried changing the permissions with chmod and get the same error. How do I give the sftp user the ability to delete and upload call recordings?

Elevate youself by SU -
allow login with root by this tutorial

1. Remote access using the root user.

By default, you cannot remotely access the server using the root user. This can be changed by modifying the “sshd_config” file. First, log in as root directly on the terminal. Then, edit the following file using nano.

root@debian~:# nano /etc/ssh/sshd_config

Change the line.

#PermitRootLogin prohibit-password


#PermitRootLogIn yes

You can use SCP then migrate them manually to

Then change owner to asterisk and the group to asterist
Then The permision for file to 0644


I had no idea root was disabled by default! Thank you very much!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.