Unable to register sip Extentions

Capture

Hi @nahid,

It would be useful if you share the following:

  • Screenshots of your Extension Configurations on VitalPBX
  • Screenshots of your Phone or Softphone Configurations
  • Version of VitalPBX

image

image

Are you using VitalPBX 3 or 2?

For new installations of VitalPBX 3, the PJSIP runs on port 5060 and SIP runs over port 5062. You can verify this information in the PJSIP Settings and SIP Settings modules.

Remember SIP has been deprecated by Asterisk, so if this is a new installation, I recommend you to use PJSIP instead of SIP.

Capture

For new installations of VitalPBX 3, the PJSIP runs on port 5060 and SIP runs over port 5062. You can verify this information in the PJSIP Settings and SIP Settings modules.

Remember SIP has been deprecated by Asterisk, so if this is a new installation, I recommend you to use PJSIP instead of SIP.

If you want to use SIP, remember to add port 5062 at the end of the IP address. e.g: 192.168.0.107:5062

1 Like

hi ,its registered now , can i disable PJSIP

No, PJSIP cannot be disabled.

can I change the port

Yes, you can change the port in the PJSIP Settings and SIP Settings module.

Worth mentioning, SIP (chan_sip) is depracated and will soon be removed from Asterisk. The earlier you learn PJSIP, the sooner you’ll master it.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.