The connection could not be established to my PBX

Hi.
I’m trying to run VitXi and make test calls, but I’ve got a mistake.
I updated the admin in preference and added the prepared extension for WebRTC.

Here is this mistake:
image

As I understood, port 8089 is not available and the admin from VitXi couldn’t make a connection to PBX

In Admin → Firewall → Rules, I have added the rule “Asterisk HTTP Daemon” which allows users from VitXi to connect on 8088 and 8089 ports.

I have checked if there 8088 and 8089 ports are on listening mode, here is the result:
image

What did I do it wrong?
I’ll appreciate any help!

What version of VitXi are you running? What happens when you open that link?

The version of VitXi I’m running is 1.1.0-2.
When I try to open that link I am redirected to https://devel.vitalpbx.com:8089/ website which can’t be reached

Update to the latest version 1.1.0-3 and see if the issue persists.

1 Like

It didn’t help, the issue has still persisted

What happens when you go to https://your.domain:8089 ?

When I go to https://domain:8089 I got 404 response, not found, the request URL was not found on this server, Asterisk/18.10.0

Go to SIP Settings and disable WebSocket if it is enabled.

Then reload the firewall:

firewall-cmd --reload

Finally, reload asterisk:

asterisk -rx “core reload”.

Try to connect to VitXi and check if the extension is registered correctly.

I enabled and then disabled Websocket in SIP settings.

Then I reloaded firewall and asterisk.

Unfortunately, it didn’t work.

Finally, I went to check if the extension is registered correctly and I noticed that there are no “Send Push” and “VitXi Client” switchers. Is that matter?
image

I was following this video to set up the extension, where these switchers are present:

Check that you have installed the “VitXi Licensing Server” module

I can’t believe I missed that. Thank you, now it works right!

1 Like

Hello, I have VitXi Licensing Server module installed, and error persist, and just per 2 or 3 seconds this i got this screen and then start working again.