TEL protocol on Vitxi Webrtc

Hi Sir,

What do you mean by TEL protocol like this?

1
2

Number will move to webrtc? But why is the format a bit weird? is there a sign (/slash/)? My previous assumption was the same as click to call, when I click on a number from “CRM Web” it automatically dials.

Thanks

1 Like

Hi sir,

Could you please provide us with information about the browser you use, as well as the operating system?

Also, the format of the link is usually as follows: tel:+11234567890. In VitXi it will show only the value (without the “tel” protocol): +1123234567890

are you suggesting that the number be called automatically?

Hi Sir,

Chrome : Version 101.0.4951.67 (Official Build) (64-bit)

<a href="tel:+081375161302">Call 081375161302</a>

Now it show

image

Hi Sir,

Yes, Need to called automatically. So I no longer need to open the vitxi page to press the dial button

Thanks

This is begging for poor UX… Do you really want everytime you accidentally click a number to auto dial it?..

It seems like you are looking for a automated click to call which can be done via the VitalPBX API.

(The only problem I see with the current click to dial, is that ot launches a new instance of VitXi instead of populating the number in the current instance)

1 Like

You are right, but if using API then I have to map between extension with “user” or “agent”.

You are right, every time click number will be launches a new instance of VitXi

@PitzKey is right, there could be accidental clicks on links and this can affect the user experience.

Yes, a new instance of the application is currently being created. A new version of Chromium is expected to be available in mid-June. This version will have the Launch Handler API, with which we developers will be able to control how the application is launched.

1 Like

Hi @maynor

Thanks for the information about the new release in the middle of june.

By the way.

This will be fix the issue of open a new webrtc app for each click in number in browser or in excel file?

image

I can’t have the number in the webrtc when I click in one number in edge , chromer browser’s or in excel file,

image

I tried with different sintases, but the result is the same:

<a href="tel:+1234">Call 1234</a>

or

<a href="tel:/1234">Call 1234</a>

image

image

This is could be a configuration problem of my side or this will be fixed in the new release?

Hi Sir,

As I mentioned in my previous answer, this will depend on when the “Launch Handler API” is available, which will prevent multiple instances of the app from being created.

Apparently, you don’t get the number when VitXi is in responsive/mobile mode.

When in desktop mode, the number appears correctly.

1 Like

Hi @maynor ,

After I update to the new version,

image

We are receiving this alert:

image

We don’t change anything, just update to the new version.

image

The port is allowed.

I don’t see any log’s about this. I had reinstaled the VitXI and restarted the VitalPBX but don’t resolve.

Hi Sir,

You may run this command in the terminal:

systemctl restart vitxi

Then, check if port 8089 is enabled: https://your-server:8089

1 Like

If the port is enabled, when accessing https://your-server:8089 you will see a page with a message “Not Found”

1 Like

I did that, but the issue still carry on:

image

Not /8089, you need :8089

This is what it should look like:

image

Also. Thinking now, it could be that VitalPBX/VitXi/Asterisk is configured to validate the SSL against trusted CAs (Certificate Authorities). Since it looks like you are using a self signed certificate, I am curious if that could be related. Tagging @maynor for clarification.

1 Like

This may be the issue of High Availability .

We had made some tests with High Availability, and we have some issues with some features. This is could be the one of the features, because we had problems with our customer certificate after configure Hight Availability.

Thanks for quickly support and response. @maynor

1 Like

Right, it is recommended to use a valid ssl certificate. Even WebRTC is quite restrictive and only allows valid certificates.

When using self-signed certificates, they usually give connection errors.

Also, as @jppedrosa mentions, it could be something related to High Availability.

no problem! let us know if you solve the HA issue,

1 Like

After remove the feature of High Availability and apply again my custom certificate one the only one server that are working the error never appeared again. The certificate is ok.

Now when I try to change the new role of one user and add the phone books to him that he had created, I receive this alert.

image

The version is that:

image

The issue of open a new webrtc app for each click in number in browser or in excel file still happen.

image