Softphone with BLF

Looking for a windows/mac softphone that has BLF features.

have used the communicator app in past but that has been removed.

Tried using things like zoiper pro but couldnt get blf to work

Any suggestions?

For windows:

Microsip via the contacts tab lets you check the BLF status of contacts you have added and set to track their Presence.

image

Phonerlite also allows you to add people to the phonebook and track their status there. They also allow up to five button with contacts from the phonebook showing their status as well.
image
Not sure how to change it but their status is inverted to me, green for them is the phone is on a call and red the phone can receive calls.

Mac I have no clue.

I literally was just testing microsip but cant get blf to work!

I have enabled presence on the contact settings and in the account settings.

Am i missing something?

Thanks

some screenshots

image

image

image

You are tracking the status of a tenant extension, so it will not be just 102, most likely T2_102. To confirm exactly what you need to track, go into the console of your server and do a core show hints.

I also testing on a single tenant install and same thing. I also changed to T2_102 and still nothing.

However Phonerlite worked perfectly. Just a little confusing with the blf colours =D

Just trying to get to the bottom if its a softphone issue or a pbx issue. The desk phones work perfect just cant seem to get the softphones working (apart from phonerlite =D)

I also use single tenant and the simple number works always in Microsip. On phoner lite you also tested with extension 102? The BLF colors and icons for phoner lite are certainly odd for me as well.

102@T2_extension-hin: pjsip/T2_102&pjsip/T  State:Idle            Presence:not_set         Watchers 11

This is what i get when hitting core show hints

On phonerlite i used just 102 and it worked. Didn’t need to add the Tenant prefix.

Again tried on multitenant using just 102 and also T2_102 and wouldn’t show on Microsip
Tried on single tenant install and same as above however single tenant doesn’t have the tenant prefix =D

Thanks

Yeah from that it doesn’t seem you need the tenant prefix at all. It really should work properly in Microsip as well. Maybe the app is glitched at this time or there is some bug in the current version, I am still running 3.20.7

Thanks for the assist, I tried downloading the version you are using but same issue. I will install on a different computer tomorrow. I have been testing multiple softphones etc on this one so probably confused.

Atleast i have 1 working as a temp solutions for now.

Would be good if someone just designed some software to just view BLF keys. Rather than using switchboard etc.

Thanks again!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.