SMTP sending issues with vitxi

I have issue making SMTP from vixit working.

We get the following error message

The mail could not be sent
Connection could not be established with host XXXXXX.XXXX :stream_socket_client(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed

Which makes no sense to me, as the cert I fully valid

Where and when do you get this error?

1 Like

Hello Sir,

Try changing the media encryption from TLS to SSL and set the port to 465.

Good afternoon,
I have tried both TLS and SSL
Changed port etc

Tried on 3 different smtps
Same results

Do you have a self-signed certificate? or do you have a valid one?

We have a valid one,

Correct me if I am wrong. It looks like the mail server’s cert is not valid.

Does the same configuration work within the PBX’s mail settings?

same settings works perfect with the PBX,

I am also seeing this issue on Vitxi Version 1.0.6-6
The same smtp settings on the Vitalpbx gui work without an issue

1 Like

Hello Sir,

Can you share a screenshot of your email settings on VitalPBX?

Best Regards!