SIP trunk won't register

Hi… I have an issue withPJSIP registration on VitalPBX4. My SIP provider uses username, password and IP for registration.


Please share a screenshot of your Trunk configuration

This appears to be a user/pass auth. Can you please try IP auth and please share the entire configuration.

Then, from the Asterisk Console, run

pjsip set logger on

Try to place an incoming call, press Ctrl + C, post the output to and share here.
Repeat the same steps for an outgoing call.

For incoming calls, you need to set up the same domain or the list of IPs provided by your VoIP provider in the match field.

If this is a trunk that requires registration, then you have to enable the “Require Registration” field.

If you go to the VitalPBX Website, you can find in our blog post integrations with different VoIP providers using different auth methods that can be similar to what your provider is requesting.

This is an example of Vonage using Registration parameters and IP match for incoming calls:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.