SIP Registration 404 Not Found

SIP Registration failed and got ‘404 Not Found’ code when SIP Account login to Yealink DECT W52P|W56P. But when SIP Account login with soft-phone (Zoiper), SIP Registration is Success.

Call Flow

                                 Call flow for 4_2812107683@192.168.104.254 (Color by Request/Response)
                                                                    │REGISTER sip:10.17.28.11:5060 SIP/2.0
         10.17.28.7:5060               10.17.28.11:5060             │Via: SIP/2.0/UDP 10.17.28.7:5060;branch=z9hG4bK727295058;rport
      ──────────┬─────────          ──────────┬─────────            │From: "Extension Name" <sip:000024@10.17.28.11:5060>;tag=2478142817
                │          REGISTER           │                     │To: "Extension Name" <sip:000024@10.17.28.11:5060>

07:00:49.382522 │ ──────────────────────────> │ │Call-ID: 4_2812107683@192.168.104.254
+0.000724 │ 404 Not Found │ │CSeq: 1 REGISTER
07:00:49.383246 │ <────────────────────────── │ │Contact: sip:000024@10.17.28.7:5060
│ │ │Allow: INVITE, INFO, PRACK, ACK, BYE, CANCEL, OPTIONS, NOTIFY, REGISTER
│ │ │SUBSCRIBE, REFER, PUBLISH, UPDATE, MESSAGE
│ │ │Max-Forwards: 70
│ │ │User-Agent: Yealink W52P 25.81.0.60
│ │ │Expires: 3600
│ │ │Allow-Events: talk,hold,conference,refer,check-sync
│ │ │Line: 5
│ │ │Content-Length: 0

                                                                    │SIP/2.0 404 Not Found
         10.17.28.7:5060               10.17.28.11:5060             │Via: SIP/2.0/UDP 10.17.28.7:5060;rport=5060;received=10.17.28.7;branch=
      ──────────┬─────────          ──────────┬─────────            │hG4bK727295058
                │          REGISTER           │                     │Call-ID: 4_2812107683@192.168.104.254

07:00:49.382522 │ ──────────────────────────> │ │From: “Extension Name” sip:000024@10.17.28.11;tag=2478142817
+0.000724 │ 404 Not Found │ │To: “Extension Name” sip:000024@10.17.28.11;tag=z9hG4bK727295058
07:00:49.383246 │ <────────────────────────── │ │CSeq: 1 REGISTER
│ │ │Server: VitalPBX
│ │ │Content-Length: 0
│ │ │

To: “Extension Name” sip:000024@10.17.28.11:5060
Call-ID: 4_2812107683@192.168.104.254
CSeq: 1 REGISTER
Contact: sip:000024@10.17.28.7:5060
Allow: INVITE, INFO, PRACK, ACK, BYE, CANCEL, OPTIONS, NOTIFY, REGISTER, SUBSCRIBE, REFER, PUBLISH, UPDATE, MESSAGE
Max-Forwards: 70
User-Agent: Yealink W52P 25.81.0.60
Expires: 3600
Allow-Events: talk,hold,conference,refer,check-sync
Line: 5
Content-Length: 0

2022/10/29 07:00:49.383246 10.17.28.11:5060 → 10.17.28.7:5060
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 10.17.28.7:5060;rport=5060;received=10.17.28.7;branch=z9hG4bK727295058
Call-ID: 4_2812107683@192.168.104.254
From: “Extension Name” sip:000024@10.17.28.11;tag=2478142817
To: “Extension Name” sip:000024@10.17.28.11;tag=z9hG4bK727295058
CSeq: 1 REGISTER
Server: VitalPBX
Content-Length: 0

Hi @Htun_Min_Myat and welcome to the forums.

Assuming you are using PJSIP, please enabled debug, redo the registration attempt, post the output to pastebin.com and share the link here.

(Enable debug: pjsip set logger on)

Hi @PitzKey and thanks for your reply.

Now, the problem is solved when I changed the IP address in the Match Section of the Trunk Setting. Because I assigned IP Address with the Subnet in the Match Section of the Trunk Setting.

LOG:
res_pjsip_registrar.c: AOR ‘’ not found for endpoint ‘sip-trunk-user’

Please provide a screenshot from your Trunk config

https://drive.google.com/file/d/1JCgIc8WgYGR6d0DUC75BBvwhO55xaKTB/view?usp=share_link

https://drive.google.com/file/d/1BvNqHF_8J10Cr5yIwGqh4m1qO4hqSPHr/view?usp=share_link

Here it is hyphens, in your screenshot it is underscores between the words.

I have w52P and password length was the issue. Not over 7 characters worked for me.