Remove trunk prepend from phone display

I have a trunk that requires a prepend (123456) I have this set in the Trunk dialing manipulation rules and call are working fine but this shows on the phone lcd when dialing out. (123456xxxxxxxxxx)
Is it possible to not show the prepend digits on the phone just the number dialed (xxxxxxxxx)

This is what the prefix in outbound routes is for.

Yes I understand that and it works perfectly, but the user dialing on the phone dials 10 digits and presses send then the display on the phone will show all the digits dialed by the pbx which looks strange to them, so is there away to not display prepend digits inserted by the pbx on the phone.

Disable Remote Party ID.

I think what you want is to remove or prepend the 123456 from the physical phone itself and just show the 10 digit number when dialing. From my experience, I don’t think that is even possible. any digit you hit on the phone during off/on hook will most likely show no matter what.

The digits are not dialed by the phone they are prepended by the pbx before it is sent to the trunk provider, Disable remote party ID did not change what is displayed on the phone.

Where did you disable it?

We have a new parameter on VitalPBX 4 that might help.
image

On VitalPBX 3, you can add this parameter under the Advanced tab:
image

1 Like

I added the new parameter in the advanced tab on V3 and it works, phone display shows number as dialed.

Thank you all for the responses.

PitzKey: I had disabled it in Device Profiles.

IIRC, it also has to be disabled on the phone itself.

I’m glad you got it working

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.