PJSIP settings on a VPS

What should be the PJSIP settings for VitalPBX on a VPS

in particular the NAT settings.
I tried different combinations but I am getting either “One way audio” or “no audio”

These are the NAT settings I see in PJSIP settings:

External Media Address:
External Signal Address:
Local Net:

VPS public IP is
Internal IP is

BTW Networks settings only show “hostname” no NAT

Using the command ip a you can get the public IP of your server and the internal IP range. So, you must place the public IP in the External Media/Signaling fields and the internal range in the local network field.

If you continue having issues after saving and applying the NAT settings, then you should check your PJSIP Profile configurations and check the codecs used by your provider and the desk phones.

Moreover, you can use the tool ‘SNGREP’ for better troubleshooting.

sngrep -c -r

I appreciate the answer, " ip a " is not showing me public or LAN IP’s .

debian@vitalpbx:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: enp0s6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9000 qdisc pfifo_fast state UP group default qlen 1000
    link/ether 02:00:17:16:9a:34 brd ff:ff:ff:ff:ff:ff
    inet brd scope global dynamic enp0s6
       valid_lft 59456sec preferred_lft 59456sec
    inet6 fe80::17ff:fe16:9a34/64 scope link
       valid_lft forever preferred_lft forever

looking in the control panel, I should be putting these into NAT settings ?

External Media Address:
External Signal Address:
Local Net:

Your public IP is given by the VPS provider. about the Local Network, it should be

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.