Permission Denied error when attempting to send fax via web UI.

It seems I am unable to send faxes using the web ui.

I’ve run vitalpbx --check-integrity as well as attempted the other fixes found here: Fax not working but none of those have worked.

Any other fixes to try?

How about those 3 lines?

All packages are up to date.

Virtual Faxes addon shows as 4.0.1-2

I also re-installed the virtual faxes add-on through the add-ons manager page. Same error.

YES you did this. Lets see if somebody else has an idea.

Please tell me if you did this:

sudo apt clean all
sudo apt update
sudo apt upgrade -y

No problem here on latest Vital4, but it is a relatively clean installation.

Share the permissions of the error files and folders in the error message.

I just saw as I was creating that pastebin post, the ‘virtual_faxes.php’ file was user:group root:root. Changing that to www-data:www-data did NOT solve the issue.

Run the commands below using root privileges!

chown www-data:asterisk /var/lib/vitalpbx/fax
chown asterisk:www-data /var/lib/vitalpbx/fax/recvd
chown asterisk:www-data /var/lib/vitalpbx/fax/sent
chmod 2775 /var/lib/vitalpbx/fax
chmod 2775 /var/lib/vitalpbx/fax/recvd
chmod 2775 /var/lib/vitalpbx/fax/sent

No luck, same error.