Parking timesout not going to timeout destination

I have an IVR that calls a ring group after it rings it goes to Parking.
timeout destination has another IVR that gives the caller the option to
0 - continue to hold
5 - End call
9 - Leave a message

The issue is that the Parking times out in 20 seconds and does not go to timeout destination no matter what the choice is in it.

Which version of VitalPBX are you using?
Is this a multi tenant system?

Assuming it’s a non multi-tenant system, please provide a screenshot of your parking settings as well as the output of the following commands (please post the output in preformatted text)

asterisk -x"parking show"
cat /etc/asterisk/vitalpbx/res_parking__50-1-extensions.conf

Below : asterisk -x"parking show"

Version : 3.1.6-1
Asterisk : Asterisk 18.10.0
Linux Version : CentOS Linux release 7.9.2009 (Core)
Welcome to : vitalpbx.local
Uptime : 5:31
Load : Last Minute: 0.18, Last 5 Minutes: 0.12, Last 15 Minutes: 0.13
Users : 2 users
IP Address :
Clock : Wed 2022-03-23 19:53:22 EDT
NTP Sync. : yes

[root@vitalpbx ~]# asterisk -x"parking show"

Parking General Options

Dynamic Parking : no

Parking Lot: default

Parking Extension : 700
Parking Context : parkedcalls
Parking Spaces : 701-750
Parking Time : 45 sec
Comeback to Origin : yes
Comeback Context : parkedcallstimeout (comebacktoorigin=yes, not used)
Comeback Dial Time : 30 sec
MusicOnHold Class :
Enabled : yes
Dynamic : no

Parking Lot: parking-1

Parking Extension : 700
Parking Context : parking-1-parkedcalls
Parking Spaces : 701-703
Parking Time : 20 sec
Comeback to Origin : yes
Comeback Context : parking-1-parkedcallstimeout (comebacktoorigin=yes, not used)
Comeback Dial Time : 60 sec
MusicOnHold Class : moh2
Enabled : yes
Dynamic : no

[root@vitalpbx ~]# asterisk -x"parking show"

Below : cat /etc/asterisk/vitalpbx/res_parking__50-1-extensions.conf

; *********************************************************************************
; @Date : Wed Mar 23 19:07:11 GMT 2022
; @Document : res_parking__50-1-extensions.conf
; @Author : VitalPBX
; @Platform : VitalPBX
; *********************************************************************************

[parking-1]
parkext=>700
context=>parking-1-parkedcalls
comebackcontext=parking-1-parkedcallstimeout
courtesytone=beep
parkpos=>701-703
parkedmusicclass=moh2
parkingtime=>20
comebackdialtime=60
parkedplay=both
parkedcalltransfers=both
parkedcallreparking=both
parkedcallhangup=both
findslot=>first
parkext_exclusive=yes

Below : Vitalpbx settings GUI

image

The GUI and Asterisk config are matching. What happens when your increase the parking tine in the GUI?

You mentioned that it never reaches the timeout. Sorry I missed that… What happens to the call?

Can you post a call trace via pastebin?

We will check this with the team. It seems that the parameter “comebacktoorigin” is not generated.

Hello Gentlemen,

Joe is correct with the parameter "comebacktoorigin issue… I added the the parameter with the value “no” to the

cat /etc/asterisk/vitalpbx/res_parking__50-1-extensions.conf

and it works correctly now.

Thank you.

I have to add that if you make changes to parking and re-save, the parameter, it disappears and you have to add it back manually again. So the team should look into this for the next update

For now until fixed:
Copy everything into /etc/asterisk/vitalpbx/res_parking__49-1-extensions.conf
Watch permissions.
Make your changes.
Reload dialplan.
Done. Will stay there.

I’m experiencing a similar issue where calls are ringing back to the originator, but then failing to hit the timeout destination after the comeback dial time. Is there a timeline on the fix for this? Or perhaps some comprehensive steps to repair the issue in the meantime? The above resolution did not correct the issue for me.

Put parameter

comebacktoorigin=no

at the end of the file mentioned originally and save it and reboot. It worked for me.

@TCE Paul, I think you have a different issue. From what I understand you are trying to catch the call in an event where the park originator failed to answer. Is that correct?

No reboot is necessary here. Do a asterisk -x"core reload" and you are good to go.

We will release an update this week that solves a couple of issues related to the parking module. Please stay tuned!!

1 Like

@PitzKey yes my issue is different after further review.

@miguel Jose, is my issue one of those?

Can you test the latest update?

I will test it out soon

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.