No call audio after update to 1.0.5-6

It appears that ever since the VPBX update to 3.1.0-1 and VitXi update to 1.0.5-6, not getting any call audio. The mic is working. Camera is working. Keypresses are sending back audio, but no call audio. The only change from last week when it worked and this week when it doesn’t is the update.

Hi Sir,

No audio in both directions? or only in one direction, there is no audio?

There’s two things that I can think of.

  1. In the recent update, a new MS Teams add-on was introduced, and it may or may not cause issues if not configured properly. If you have it installed, try uninstalling it.
  2. Your network settings are misconfigured, and since Asterisk is restarted when updating the PBX, it probably started sending/listening [for] traffic on a wrong address.

To troubleshoot, please describe your network and setup, and then at the asterisk console enable PJSIP debugging

pjsip set logger on

Or if there is too much “noise” from other extensions, you can run:

pjsip set logger host <host IP>

Dial *72 to run a echo test.

Copy/paste to pastebin.com and post the link here.

1 Like

I reemphasize… No changes were made to VitalPBX nor VitXi web, other than the update.

Kind of difficult to do an echo test when you can’t hear the echo. lol

Look, I put this out here in the public forum to see if others are seeing the same problem. The problem also occurs in VitXi+ mobile app. The common denominator is the ‘Default WebRTC Profile’ that the extensions/devices are using. If I tell VitXi+ to use the default extension device which uses the ‘Default PJSIP Profile’, it works fine.

We’re using PJSIP port 5062. Maynor I’d start there to see if that’s where all this is originating from. Others may not be reporting this problem since they’re using 5060. I’m in the way-back club now of users who migrated from v2 to v3.

WebRTC profile settings:
webrtc_profile_1
webrtc_profile_2

RTP settings:
rtp_settings

VitXi web ICE settings:
vitxi_ice

In the WebRTC profile you must select the SSL certificate in the “DTLS Certificate” field, also disable the “Direct Media” and the “Asymmetric RTP Codec”.

Remember that for the devices that will be used in VitXi Mobile, you must assign them the PJSIP profile, and for the devices that will be used in VitXi WebRTC, you must assign them the WebRTC profile. These are due to the differences in their configurations so that they work correctly.

Also, we inform you that the new version of VitXi WebRTC is now available!

You can see our changelog at the following link: VitalPBX Phone System | Change Log

I am aware of the profile assignment requirement. That is why I specifically included screenshots of that WebRTC profile. Below is a screenshot of an extension assigned to that profile.

I must apparently reiterate vociferously… We had a fully functioning VitXi WebRTC system with many users using the tool, both web and mobile. It BROKE as soon as we did the VitalPBX update over this past weekend. We did not install the Microsoft Teams plugin. I personally cannot fathom why anyone would do that on a platform that already supplies VitXi, but that’s here nor there.

Something under the hood changed and broke the audio for VitXi clients. We’re using PJSIP port 5062. All other aspects of the VitalPBX system are nominal. Just did the update of VitXi to 1.0.6-1. Very pretty, but still no audio.

extension_device

1 Like

Oh ok, I understand.

Some settings may not have been preserved.

Make the following settings in the “RTP Settings” module:

  1. Disable Strict RTP.
  2. Disable RTP Checksums.
  3. Enable ICE Support.

Made the above recommended changes. Still no audio from VitXi web nor mobile.

If you make a network change, it sometimes won’t go into affect until Asterisk is restarted.

You are missing the point… This is part of the troubleshooting steps along with gathering the logs.

Guessing is always hard, once we understand your network setup and can see the SIP trace and Asterisk logs, we might get a clue on whats wrong.

1 Like

Also, if your PBX server is behind a one-to-one NAT, you will need to define which IP addresses will be exposed during the ICE negotiations.
image

This option was added in VitalPBX v3.0.4

Okay Maynor you found it! We’re running on a cloud service, so it’s technically a one2one NAT (I guess). That’s a debate for another day.

Remember, all was well in version 3.0.9-5, so obviously something was changed in this latest update to 3.1.0-1 that took into consideration the ICE settings. You can see my original ICE settings in the above screenshot.

So with defining these ICE Host Settings, per the title tip I removed the Stun Server setting. However, in VitXi WebRTC under Administration → Ice Servers, it will not allow me to delete both entries that were there.

ice_ice_baby

It forces at least an entry there. While everything is working right now, how should I proceed with this setting? Leave the STUN servers as is, or remove? Which your title tip says to remove.

I appreciate your help PitzKey. It’s often impossible to pre-attach a resume to requests for help in public forums so that we can all skip beyond the “reboot your computer” kind of suggestions. I’ve been doing this for decades now, longer than most in this forum have been alive. I did come out of the gate with “Did an update… stopped working”. Updates require and do restarts. I think that was a good enough starting point for everyone.

I don’t want you to get discouraged by me from helping others, but please read between the lines and try to save the “reboot your computer” and “show us the logs” for those that do choose to not provide much detail when posting to forums. That was not the case here with no less than half a dozen paragraphs and screenshots provided.

Perfect Sir!

In WebRTC iceServers are required, so in VitXi you cannot leave without any iceServer. What you can do is remove the value you have in the “Stun Server” field in the RTP settings.

In VitXi WebRTC, you can leave the iceServers that come by default. But it is advisable to have your own because if these Google servers go down (normally these servers are stable), calls by VitXi WebRTC could not be made.

Understood. Does VitalPBX offer these? ICE/STUN/TURN

1 Like

No, we do not offer. But there are useful tutorials online on how to create your own STUN/TURN server with coturn