No audio on VitalPBX Connect App

I can, place calls and receive calls aslong as I am on LAN but on WAN (Away) it doesn’t come through

These are my firewall settings. What am I missing

Is the remote extension registering? What you are seeing on the phone server side. Showing the firewall rules of the phone server will help troubleshoot as well.

Remote Extension Registers just fine. I can call a phone. It will ring. Pickup and dead silence. And vise versa. Unless you are on LAN side. All is normal.

Ok, so it will have to be RTP audio not passing your firewall and reaching the server properly. Ssh into your server and start sngrep, filter for notify packets and test doing a call from a remote extension to confirm or not if RTP is passing properly, get some logs from there. F3 enables the RTP packets to be showed (if any) in sngrep.

Dont currently use fortigate but test enabling NAT as well on the rules.

114 - 146 is logs doing both directions while on WAN

190-193 is logs doing both directions while on LAN

This is also with NAT now enabled on the rules. I added 6001 for the sake of curiosity before doing this.

Nothing has changed.

In sngrep go into the actual items to see the details each leg of the call.

This helpful?

The silence is due to the pbx RTP is behind NAT

Go to RTP Settings .
In Advertising addresses . Put the ip internal ip and in Advertising address the public ip

This information has already been added

Decheck Strict RTP and Check ICE Support

it appears there is still no change with those options

Could you please take screenshot of the pjsip profile you use?

No please go to
Device Profile → Default PJSIP Profile

The call is not getting established at all due to the 415 Unsopported media type error on the acrobits server side.

Show the app settings, codecs have to match what is set on the extension device and the same goes for the extension profile it must match how the extension is getting set on the app.

Doesn’t explain why it works fine on LAN but not WAN. I think this is a firewall issue.

Create a new profile . Copy this setting except .

  1. DECHECK Direct Media
  2. CHECK ICE Support
  3. DECHECK RTP Symmetric

And try to make a call after assgin the new profile to the extension

I’m starting to believe that my problem might be the Fortinet Firewall blocking traffic. I want to setup DMZ However based on my experience with Fortinet routers, DMZ can only be on a seperate VLAN. Therefore I added a second NIC in Hyper-V

The question is, How do I get the second NIC enabled in VitalPBX?

Grab sngrep logs from a working call from the app while in the LAN and compare the flow to the ones from the WAN.

I decided to move VitalPBX to another older Cisco RV320 router. Once I changed the IP settings in the PBX and DMZ’d the IP of VitalPBX in the router. Everything works now.

The VoIP Phones remain on the main network and are getting through via WAN to VitalPBX.

The Fortigate is not getting communication for the audio through the firewall. I am not sure how to approach the issue but I am going to keep VitalPBX on a seperate router to ensure reliability for now until I have more time to dive into the issue.