New trunk to

I mentioned in my previous post that I’m porting a number to but I have not had any success getting a trunk to register. I have a working trunk with Anveo so my infrastructure is not broken.

I’m using the main account only as I need just one trunk and one DID so I have not done anything with subaccounts. I do not have a DID at this time as I am trying to get the trunk up before the porting request.

I have followed the wiki page for Vitalpbx here
and a page I found for v3.x here PJSIP Trunking On VitalPBX 3

I just upgraded VitalPBX to 4.0.5.

What I see…

Reports → PBX Reports → PJSIP Endpoints - shows is reachable. The 33#### is the Endpoint and my Main SIP user id.

Reports → PBX Reports → Registrations - lists both trunks (Anveo and but no registration for

When I save the config and reload, asterisk gives this error.

[2023-10-06 16:19:22] ERROR[8275]: res_pjsip_outbound_registration.c:1984 sip_outbound_registration_apply: Client URI or hostname length exceeds pjproject limit or is not a sip(s) uri: 'voipms'
[2023-10-06 16:19:22] ERROR[8275]: res_sorcery_config.c:422 sorcery_config_internal_load: Could not create an object of type 'registration' with id 'voipms' from configuration file 'pjsip.conf'

The only place I have “voipms” on the trunk config page is in the Local username.

I’m running pfSense as the firewall and for outbound connections I don’t think I need to do anything special.

Could anybody share a working config or screenshots for this?


I would like to see your VoIP MS configurations!

Hi BossyBear, hope your having a wonderful day!.. I have a trunk configured and working. There are 2 ways to create a trunk with VOIP.MS

  1. PJSIP using User and Password Authentication

  2. PJSIP using IP Authentication FOR ADVANCED USERS (to be able to use IP authentication you will need to create a sub-account. The main account is not capable of handling this type of authentication)

I’m using option 2 since i have a static IP using PalAlto Networks. Ill send screenshots to both just incase you choose either one.

OPTIONS 1 Settings

OPTION 2 Settings

Create a Sub account on VOIP.MS and copy the settings… You will need to put your public IP.

You will have to create an INBOUND ROUTE & OUTBOUND ROUTE as well.

I purchased a DID and assigned it to the POP I am using to see if it helps. I’ll drop it once the port in is complete.

@miguel Here are my screenshots.

@danny Thank you for your pics. These look familiar and I am trying to use option 1 with the main account. The Outbound default route is still to Anveo because that’s working. Inbound is working. But I don’t think either of those settings matter with regard to the outbound registration for an additional trunk.

Thanks for the help.

I see some issues on your screenshots… Is the username 384609 or 385609 ?

Remove voipms under Local Username to > 384609 or 385609 which ever one is correct.
Remove From Domain and change it to
fix Contacts with the correct username

*IMPORTANT: The Main and Sub-Accounts use codec G.711u as priority by default. To use G.722 go to the advanced settings of the account you’ll configure in the trunk.

Also don’t forget to whitelist voipms in VitalPBX and your Firewall
Admin >> Firewall >> Access Control

everything else looks good.

Thanks @danny it’s 384 and I’ve fixed that. I’ve typed it so many times on that page trying to get anything to work I just fat fingered it.

Changed local Username.
Changed From domain.
Changed Contacts.
Updated the trunk to g.722 since I don’t see G.711u in VitalPBX.

I’ve whitelisted the server but I don’t know if that is for outbound or just inbound. I don’t have anveo added there and it works fine.

On reload asterisk says…

ERROR[31376]: res_pjsip_outbound_registration.c:1984 sip_outbound_registration_apply: Client URI or hostname length exceeds pjproject limit or is not a sip(s) uri: '384609'

Is this a your main account or sub-account?

@danny Main account with the new DID and dallas2 set.

Looks like your main account…go to and do the following.

Main Menu > Account Settings

Under Inbound Settings make sure the following settings are set.

Protocol for inbound DIDs: > SIP
Device type: > IP PBX Server, Asterisk, Or Softswitch

Under Default DID Routing make sure the following settings are set

DID POP (United States) Dallas2,TX (make sure is checked)
Routing Settings > SIP/IAX (make sure your main account is set) 384609.

Try this out and let me know …

@danny I had those settings set already.




The Trunk is reachable

Just not registering.

(I chose that DID number ending in 5150 because this is making me nuts!)

Ok this is interesting. I got it to register by using the same fields that were working in Anveo and it is substantially different than anything here or in the wiki.

Well glad to hear its working for you now…!!!

I had to add the IP/mask in the match field to accept incoming calls but it i working now.

Here are the settings that matter.

We have a Voip.MS trunk registered. We utilize the IP Authentication.

This is all that I’ve had to put in VitalPBX to get the trunk to register.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.