New Install of VitalPBX 4.0

Hello, I have a new install of VitalPBX 4.0. I disabled the firewall and saved the settings. However, the firewall does not stay permanently disabled. On Reboot, the firewall is switched back on again. Is this a bug?

Figured it out:

  • sudo systemctl disable firewalld
  • sudo systemctl mask --now firewalld (hides firewall systemd)

I’m NAT’d behind a hardware firewall.

As well, enabled SSH internally with password, in case others need that as well:

  • vi /etc/ssh/sshd_config
  • The config line by default says: PermitRootLogin Password-Prohibited
  • We change it to: PermitRootLogin yes
    Reboot Vital PBX after both these changes.
    You also have to change the Network Interface form the command line, they have not integrated it into the GUI yet if you want a static address. but no big deal. Easy to do.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.