Name of Caller ID not displaying

I’ve have an issue with the name from inbound caller id not displaying on vitalpbx 4, using a Vega 60 fxo gateway.

Checking if anyone else has had experience with the vega 60 or experience with editing configurations to allow the name to pass through.

I have found in the header that the vega 60g is sending the name in the P Header. Is there a way to tell the VitalPBX to look at the p header instead of the contact or from?

Asterisk is unable to get information from those headers. You should be able to configure your Vega 60G to send the Caller ID in the right headers.

When I would set the from header to send the correct info all the calls would get rejected. After searching why calls would be getting rejected, I found a thread that mentioned the match setting in the trunk settings. After setting match to be the IP address of the Vega60g, I was able to receive calls again with full Caller ID

Well after setting match IP setting, it killed the trunk registration which killed outbound calls. I believe there is something with trying to set them up under PJSIP that doesn’t work. 2 totally different fxo gateways with similar issues.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.