Multiple extension sharing single voicemail

I’ve just installed VitalPBX 3.2.2-1 to test at home, I have set up so far 5 extensions (601 to 605) all Xorcom XP0120P phones in different rooms in the house and a single VOIP trunk, all using PJsip.
All seems to be working fine, I can make and receive internal and external calls fine, but
I am completely stuck on what I thought would have been the simplest bit of the project which is how to make ALL extensions use a single common voicemail box, like an old fashioned BT answering machine.

I have a ring group (600) for all extensions, so incoming calls from the trunk ring all the extensions, if they are not answered they get sent to extension 800 which is the non existent extension with voicemail enabled.
However, when the ringing period has expired for the incoming trunk call, I get the message ‘the person at extension 800 is on the phone’ and no option to leave a message.Am I going about this the wrong way and is there a simpler way of getting all extensions to use a single voicemail?

I don’t need voicemail on each extension for internal calls like one would have in an office environment, this is simply a house with two persons and 5 extensions so we’ll never leave messages for each other.

Thank you to anyone who can offer any advice.


Hope you will love VitalPBX as much as we do.
I’ll try to help you like it.

The easiest way to only have one VM:
use a NONE as Technology. Or you use just one of the Extensions in the Ringgroup.

Maybe you disable the “Say CID”?
And dort forget the “Generate Hint”.

Then go to Asterisk CLI and type “core show hints”
It will show you VM_200 which is the Hint/BLF for the Voicemail.

On “Feature Codes” Menu have a look at the Voicemail Options

Dont forget to check you the Youtbe-Channel with a lot of HowTos.


Thank you for replying to my request, essentially that is what I have done.
My voicemail extension is 800, using technology ‘none’.
I have set the voicemail options exactly as your screenshot shows.
If I dial in from a trunk, all extensions ring, ignoring them the call drops to the voicemail,m I get the message ‘the person at extension 800 is on the phone, please leave a message or hang up’.

I can leave a message, but don’t seem to be able to retrieve it, dialling 800 from any phone inside the house, I get the same message, i.e ’ the person at extension 800 is on the phone’, please leave a message’
When I do the core show hints, my extension 800 shows

800@extension-hint : Custom:unavailable@C State: BUSY Prescense: not_set watchers 0

I am guessing that is why I get the message that the person is on the phone as it shows State : busy, whereas your screenshot shows : Idle.

What could be the reason for this?


Further bit of info, from the CLI, if I do a dialplan show extension-hints I can see

‘800’ => hint: cusom:unavailable&custom:DND_800

So I am assuming extension 800 which is the voicemail has do not disturb set, which is probably why I get the message the user is on the phone.
I have looked through the settings for extension 800 and cannot see anything for DND, so how do I remove it.
Is that something I need to do via the CLI and not the browser?


Hi Tony, please provide screenshots as well.
Have you used Voicemail Direct instead of Voicemail Busy as destination? You can use an announcement before voicemail direct.

Try with normal extension instead of none.

Cancel the last, I was looking at extension 800, the VM_800 is correct as yours is showing in the screenshot.
I restarted the pbx, and now it seems to be working of sorts, I can dial in from a trunk, and leave a message, but the MWI does not show there is a voicemail message and when dialling in from an external number, I get the prerecorded message saying leave a message after the tone , but there is no tone played.

Looking in the log I can see entries warning[3794] [c-0000007]: : : file beep does no exist in any format, unable to open beep (format ulaw): no such file or directory.
I’ve checked in the /var/lib/sounds… folder and there is a file called beep.ulaw, I downloaded the UK English sounds from ‘settings’ voice prompts, asterisk sounds, English United Kingdom) Beatrix.ulaw

How can I check which directory the error message is refering to, so far, everything else seems to work fine, I can dial 98800 to get / listento and delete messages, I will also need to make the envelope button dial that shortcode so getting voicemails is a one button operation to get into the shared mailbox.


Sorted the beep, I had originally copied the original US English sounds to a folder called EN-backupUS
before I changed to English GB by ssh’ing into the pbx as root, when I copied the sound files the owner and group had been set to root:root, I removed the entire backup folder and the beep now works so the pbx must have been looking at the files in the backup folder first.


Sorry it’s a bit fragmented I am working off two devices, the main PC is in the office which is where I am typing this, the PBX is downstairs on a different vlan with my laptop attached, so that is why I didn’t put a screenshot as the two PC’s are on different vlans.

in the ring group (600) I had set the last destination to ‘extensions’ 800 which is the voicemail,
i’ve changed that now to ‘voicemail direct’ 800 which seems to be much better, I get the message ‘please leave a message after the tone’ , I get the beep too!

Can I play a short message before this getting voicemail greeting such as ’ this is Tony’s voicemail’ or customise it as I can with busy / unavail (such as by uploading a recorded file to the /var/spool/asterisk/voicemail/vitalpbx-voicemail/800 folder?

Apologies for all the seemingly stupid questions, I am completely new to all this so staring from the ground up with the help of Google and this forum!


Use the Announcement Module for that. Uploading via Recording Management.
As destination after the Announcement you can choose Voicemail Direct again.

Best is to check the Vitalpbx Youtube Channel and/or do the Vitalpbx Course. Wiki will help as well.


Brilliant that is really cool, I am almost all sorted, I uploaded a message via the recording management, then set it as you said, I now get the greeting I uploaded and the chance to leave a message which also works.

I am super impressed with Vitalpbx so far, the final task is to get the envelope lit on the Xorcom so we know we have a voicemail,

Thank you so much for the help so far, I will certainly look at the Youtube videos, and online course when time permits,.


Use VM_200 (just my example) as MWI “number” and it should lit.
Or try it as BLF.

Sorry I don’t understand your reply, where would I set the VM_200 as the MWI number, in the PBX or the Xorcom phone?


In the Phone. Since the VM_200 is already a hint as you know in the PBX.

*98200 or * 98 *200

Unfortunately I cannot see that in the config page for the phone (Xorcom XP0120P).
There is the facility to program the line keys and arrow keys but not the key with the envelope on it.
In the config page for the phone I have set the voicemail to 98800 which when I press the envelope button does dial the voice mailbox 800, but there is no indication of a waiting message.
I also installed MicroSIP on my laptop and set that as extension 601 under voicemail number, I have set vm_800 and pressing the voicemail icon, gets me into the mailbox, but there is no indication on the screen there is a message in it even though there are several.

Could it be something in the PBX I have not set?


I currently have voicemail set to disabled in the VitalPBX brower extensions setting page for all extensions 601, 602, 603, 604 and 605 and enabled for 800 which is the shared mailbox.
If I enable Voicemail for just extension 605 in Vitalpbx extension settings, then on the extension 605 phone web page settings, set the voicemail number to 98605, then the envelope button works perfectly, if I leave a message in the extension 605 mailbox, then the button lights up and flashes green, if I delete the message then the button stops flashing.
If I now disable voicemail on extension 605 in Vitalpbx, and change the voicemail number in the extension 605 phone web config page, back to 98800 for the shared mailbox extension, then the light does not light at all even if I leave a message in mailbox 800.


Page 50: BLF

Do VM_200 as BLF-Key.
It will light up when new message.

If you have problems, try regular Extension instead of NONE as Technolgy.

I will of course try vm_200 but I don’t see the relevance of the 200 can you please explain? I have no extensions at 200, mine are 601 - 605 and 800 for the shared voicemail.

I did see in the Xorcom manual about the BSS keys, but the phone having a dedicated envelope button which lights up, made sense to use it, I will try setting a BSS key after evening meal, and setting extension 800 to PJsip, but not sure how that will work as there is no physical extension connected.


Told you VM_200 was just my example. Will be VM_800 for you then.

I think MWI only works with *97. That means only for the current extension. for a group of people.
Try *98*800 as MWI but think this will not work.

This is why you should try VM_800 as BLF.

Ahh thank you I understand now .

I have spent several hours on trying to get the MWI working, more tiome than I have spent getting the entire PBX up and running from scratch in fact, and I think the conclusion I have come to is that it doesn’t work.
I have tried every possible combination I can think of, if I set each extension to have it’s own voicemail, then the missed call / voicemail button works perfectly on all extensions.
Changing it to the common shared voicemail number 800 then the MWI does not work on ANY extension, nor the MicroSip softphone, I also borrowed a new Yealink W52p dect cordless and get exactly the same with that too.
I also installed the free 3Cx softphone, guess what, exactly the same works fine for individual mailbox, I get the message light for a voicemail, but doesn’t work for the shared mailbox.

On the Xorcom phones, I was able to program a ‘DSS key’ as BLF and the destination was vm_800 and that lit red when there was a voicemail in the inbox, and went green when there was no voicemail.
But the softphone and the Yealink don’t have that option.

In desperation, as I have spent waaaay too long on this now, I spoke to an old work telecom colleague who suggested to try what he had used some time back on Asterisk, which is to edit the extensions file directly and point the mailbox to 800@ instead of the individual extension number i.e. 601@.

Looking on the PBX, I found a file under /etc/asterisk/vitalpbx called ‘pjsip_50_1-extensions.conf’

Each device had an entry [601]
type = endpoint

I changed this line to 800@vitalpbx-voicemail in the section for all the phones, including the MicroSip one, and restarted the PBX.
It worked perfectly, leaving a voicemail now makes the envelope light on all devices flash, deleting the voicemail removes the envelope symbol of the display’s and stops the light flashing.

Obviously, I would have preferred to have got it working by using the browser configuration, and doing it this way ‘may’ have broken something else, but as yet I cannot see what, everything seems to work how I want it to.

I really appreciate the assistance in getting this working, if you can think of a reason I was not able to get the browser config to get it to work, I would love to know.

Kind Regards

Here i said everything you summed up while testing.

Interessing workaround.