Listen on additional SIP port

Hello,

Is it possible to set VitalPBX to listen on more than one SIP port?
I would like to be able to set it to 5060 and 7000 at the same time because of issues with some firewalls that like to mess up VoIP.

Thanks!
-G

Are you using a self-hosted server or VPS service?

Curious. What issues? (And what firewalls?)

If your PBX is being NAT, then some firewalls allows you to translate a port to a different port. For example wan:7000 → LAN:5060

You can also do the same thing with a SIP proxy/router such as Kamailio.

Finally, in some cases where you cannot get the phones behind NAT to work, try switching to TCP. (it will use more resources, but it’ll make your client happy)

PBX is in self-hosted and connected directly to internet.
Client is using Araknis routers, for some reason that thing refuses to work on port 5060.
The issues are that either there is no inbound to the phones or outbound from phones while phones are showing registered or phone will go unreachable after few minutes.
Normally I do not see phones registering on ports like 5060, 1024, 1025, 1026, etc. on any well known firewall, but it happens on this one.
I tried different SIP PBX that uses port 7000 and it worked fine.

Hey @GregW,

You can try the following commands.

firewall-cmd --add-masquerade

firewall-cmd --add-forward-port=port=7000:proto=udp:toport=5060
firewall-cmd --add-forward-port=port=7000:proto=tcp:toport=5060

The settings above are temporary, so executing the command below will remove the firewall rules. Setting up the rules as nonpermanent rules is useful when you are testing.

firewall-cmd --reload

If you need to make the rules permanent, you can execute the command below.

firewall-cmd --runtime-to-permanent

However, because VitalPBX alters the firewall from the GUI, if you apply any firewall changes from GUI, the changes above will get overwritten.

1 Like