Linear Strategy doesn't ring in order

When we cerate a linear queue with only static members, sometimes the order is not aplyed correctly.
The comand “queue show …” lists the order diferrently from the configured order.
image

We tryed the command “queue reload members”, tryed to remove and add the extensions, add only 1007 and then add 1003 but the result doesnt changes.

Are we doing wrong or is it a bug?

Is is possible that the queue ring strategy was something else before it was set to linear?

There’s an old Asterisk bug that requires a Asterisk restart after changing to linear.

Maybe it had another strategy before, Im note sure but is quite possible, coz we just figured out that a freshly created queue worked fine.

Try what pitzkey said and report please.

Its a little complicated to restart asterisk coz there are clients working 24/7, but Ill test it as soon as possible, maybe this weekend.

We had to reboot the whole server and the linear queues were corrected. Unfortunately we didn’t testes restarting only the asterisk, but we believe it will have the same result.
Deleting a queue and creating again with same code wont correct the order, the code must be different.

Where to exactly report this kind of issue? Thanks

Asterisk bugs? issues.asterisk.org

There’s an old ticket, noone has submitted anything sufficient.

W

Why don’t we?
“Nike, just do it”

I’ve already reported this issue to Asterisk.
https://issues.asterisk.org/jira/browse/ASTERISK-30410

1 Like

There’s already an existing ticket, a couple of years old

https://issues.asterisk.org/jira/browse/ASTERISK-17049

It doesn’t hurt to create a new report with recent data and without realtime involved.