Letsencrpt error

Trying to renew and get the following error, I also tried to delete and re-add the certificate and get the same error. This error just started recently and wasn’t an issue in the past.

Exception : Invalid response header: HTTP/1.1 100 Continue HTTP/1.1 400 Bad Request Server: nginx Date: Sat, 26 Feb 2022 23:50:27 GMT Content-Type: application/problem+json Content-Length: 133 Connection: keep-alive Boulder-Requester: 427477920 Cache-Control: public, max-age=0, no-cache Link: ;rel=“index” Replay-Nonce: 00018JTyy-YgOqWgrPOKURE3hsK_SGDgA7md3J_jKHPfPfo body: { “type”: “urn:ietf:params:acme:error:malformed”, “detail”: “NewOrder request did not specify any identifiers”, “status”: 400 } at file /usr/share/vitalpbx/www/modules/certificates/certificates.php on line 0
Capture

Are you running the latest version of VitalPBX? Is port 80 open on your server? Is your server accessible from the states?

Yes I am in the United States, port 80 and 443 is open. I am on the latest version, made sure before I posted there was no new version with a possible fix. Now since I made this post over the weekend I tried to install a commercial certificate and that worked okay except the phones didn’t like it for TLS. I then tried to do another Let’s Encrypt certificate and it worked, but now my issue is something didn’t work and while it’s working for the HTTPS it’ not working for PJSIP and SIP over TLS, it’s still looking for the commercial certificate I installed and have since went back to Let’s Encrypt.

Can you share a screenshot of how you are defining the Let’s Encrypt cert?

Capture

Certainly here you go.

That cert seems valid. It is already created and expired until May 27th.

So as I stated I got it to to work but now have another issue with Asterisk and secure connections still failing. As near as I can tell Asterisk is still looking for the commercial certificate it didn’t like in the first place and isn’t using the new LE certificate.

Did you configure the CERT in the Mini HTTP server and the PJSIP Settings modules respectively?

That is correct, it seems like it’s looking for the certificates in ‘/usr/share/vitalpbx/certificates/’ when the actual certificates are in /usr/share/vitalpbx/certificate/lcr.versadns.com

So no other ideas? Nothing else that would be the issue?

Still looking for a solution here, Thanks!

solved (last ISO) by disabling IPv6

/etc/default/grub
GRUB_CMDLINE_LINUX=“ipv6.disable=1 crashkernel=auto rhgb quiet”
grub2-mkconfig -o /boot/grub2/grub.cfg
reboot

2 Likes

That solves nothing that I was having an issue with.