Issues with PJSIP and (Opus | g722)

Dear all,

We are testing testing VitalPBX 3.1.1-1 . We managed to get everything we needed up and running using chan_sip (local calls using Opus, call through our trunk using g.722), incomming and outgoing calls, queues etc…

We are equiped with Yealink T53 SIP phones and have a 10 Mbps symmetrical dedicated line for VOIP.

We have been working with pure asterisk and chan_sip for years.

Our Yealink phones are using PJSIP as SIP stack for their firmwares, and also PJSIP is the stack privileged now by the Asterisk project so we gave a try to PJSIP. But this is where we face issues when using Opus.
Something easy to reproduce is configuring a new extension and association a new device using a PJSIP profile (on which we have enabled G722 and Opus and set Opus as prefered codec, followed by G722). If we call the voicemail, we don’t hear. If I use a Linphone device (Opus enabled), I hear a very choppy announce. It’s a little bit better for G722 but not so much. However, if I set ulaw or alaw as prefered codec, everything works correctly.

This happens only when using the pjsip chan driver, the same tests with sip chan driver give normal results.

Clément

Have you asked in the Asterisk forum about this?

1 Like

Actually, the problem came from the “Asymmetric RTP” option which was set to “Yes” in the default PJSIP profile.

1 Like