Issues with Incoming Calls After Enabling "Multi-Tenant"

Hi,

Before enabling the “multi-tenant” option, I configured an extension, trunk, outbound route, and inbound route, and both inbound and outbound calls worked perfectly. However, after enabling the “multi-tenant” option, I created a new tenant and repeated the process, configuring an extension, trunk, inbound route, and outbound route with the same credentials. In this “multi-tenant” scenario, only outbound calls are working. Inbound calls are not being redirected to the destination extension, and after two rings, the call is dropped.

I suspect the issue might be related to the prefix added to the trunk.

Does anyone know how to fix this?

If you just want to remove the tenant prefix from the trunk, you can toggle “Disable Trunks Prefix” in the tenant settings. Or, you can create the trunk on the main tenant and use a tenant trunk to route outbound/inbound calls from sub tenants through the main tenant.

If you’ve still got the same trunk enabled on the main system as you do on the new tenant, then it is possible the authentication is bouncing between your tenants with every auth cycle and messing with your inbound call flow.

I would suggest to instead instead try allowing the main tenant as an Allowed Tenant Trunk under the Tenants’ Calls & SMS Routing menu, and configure it that way. This would prevent the issue with two separate authentication attempts happening constantly.