iOS - No audio on application - same profile/extensions works on VitXi webapp.

Hello,

I have a new question. I continue to try VitalPBX and I have now a problem with iOS Apps.
I configured some extension with following setup :

  • Vitxi Client enabled
  • PJSIP Profile selected

On notebook :

  • Connected to iPhone with shared connection (to be outside of my network)
    I use chrome on OSX.
    When I use this extension on WebRTC apps , I have any sound. (All Works)

On iPhone :

  • Connected to 4G Network (to be outside of my network)
    When I use this extension on iOS , I haven’t any sound.
    When I use this extension on WebRTC apps , I haven’t any sound.
    (Chrome or Safari) → In setup page , only microphone is available , no output.

  • Connected to local Network
    When I use this extension on iOS , I have any sound. (All works)
    When I use this extension on WebRTC apps , I haven’t any sound.
    (Chrome or Safari) → In setup page , only microphone is available , no output.

On my firewall , I don’t see any blocked or deny packet to my IPBX.
My VitalPBX is behind a firewall.
My FQDN VitalPBX is behind reverse proxy (provided by my firewall).
Websocket passthrough is enabled.
I setup DNAT :

  • 8089 to VitalPBX 8089
  • 5060 to VitalPBX 5060
  • RTP UDP 10000-20000 to VitalPBX 10000-20000

Do you have any idea ?

Regards

The same answer on another topic you posted

In RTP Settings check on ICE Support
Then in ICE Hosts

Put the local adress of the Vitalpbx and in advertised adress put the public IP .

This is missing configuration

Also I think WAF or reverse proxy engine on firewall will confict on SSL certificate

Make sure thats the PBX installed the same certificate firewall uses if not working try to DNAT also the https port with valid certificate and Public domain name points on the NATed IP by A Record

Hi Mohamed,

I already checked and filled RTP settings with local VitalPBX IP and Public IP Address.
I use same certificat on all devices (WAF and VitalPBX).
It’s a wildcard real certificat (Sectigo RSA).

Public Domain DNS point to Public IP Address with A record.
It’s not possible to make DNAT on HTTPS port (443) because my WAF forward other web services on anothers servers. So if I forward HTTPS , only VitalPBX will works.

Regards

For the WebRTC devices, you have to use the profile “Default WebRTC Profile.” You cannot use the same device or profile for WebRTC devices and regular phone devices.

1 Like

Thanks Miguel.

I Opened a case on helpdesk to try to find a solution to my problem.
Alaways to RTP with VitalPBX Mobile outside of my network (ex : from 4G/5G Network)

Regards