Intercom for internal calls

Hello,

When the extension is set to auto answer internal calls it will not work if the extension Follow Me is enabled
The issue is that if the extension follow me is set on a time condition it will not work if the time does not match

Thank you

3 Likes

Hi @sama, Welcome to the community!

As a temporary solution, you can add the following 3 lines to the sub-local-dialing context before the check-hd label

 same => n,ExecIf($[$["${DB(${TENANT}/diversions/${CALL_DESTINATION}/FWM/enable)}"="yes"]&$["X${DB(${TENANT}/diversions/${CALL_DESTINATION}/FWM/time_group)}X"!="XX"]]?Set(FMTG=${DB(${TENANT}/diversions/${CALL_DESTINATION}/FWM/time_group)}))
 same => n,GosubIf($["X${FMTG}X"!="XX"]?${FMTG},s,1)
 same => n,ExecIf($[$["X${FMTG}X"!="XX"]&$["${TGMATCH}"="0"]]?Set(EXEC_AA=yes))

Let’s hope that Vital will fix this in the next update.

3 Likes

An screenshot with your configurations might help to reproduce the issue!

image
image
image

The extension have Follow Me with a time group and if the time does not match it will still be enabled in the Database and auto answer is only if follow me is disabled in the database

I guess this is solved in the latest versions. Can you please confirm?