Install issue with VitalPBX 3.1.0

I just downloaded the latest release 3.1.0-1 and started to install on hardware which meets the posted requirements X64, 4 core (J4125 celeron), 8GB & 256G, but the install is aborted with an error that the following is needed:
image

I can load up CentosOS 7 3.10.0-1160.e17.x86_64 minimal using Rufus without issue.

The systems only support UEFI and if I use Balena, they do not detect the USB. If I use Rufus, then they do and begin the startup routine.

Am uncertain if i can load up the version of CentOS 7 I had running and then get the app installed from on top or if the download distro is the only way.

Appreciate any help.

I also tried VitalPBX 3.0.6-2 from Rufus and did not get the grub errors, but continued to get the device mapper error.

Does not look like a USB issue, but rather the system hardware requires some files that are not a part of the distro.

As an aside, FPBX installs fine using 15 with Asterisk 16. Just what I had handy at the time. However they do not support Fanvil in their EPM.

Hey,

I recommend you to install Centos Minimal and then use the VPS script for installing VitalPBX.

Thanks, will give that a try and let you know.

Ok, keep me in the loop!

Worked like a champ!. Now I can do more testing.

Thanks so much.