Important: API apply_changes broke in 3.1.5

Hello,

API apply_changes seems to be broken in VitalPBX 3.1.5.

It responses with “success” and it is doing a Dialplan Reload but it is not generating the new extension_50-1-dialplan.conf for example.

If apply is done in the VitalPBX Webgui then it is working.

Please test it and fix it.

How did this happen? Thanks.

http://{{host}}/api/v2/tenants/1/apply_changes

The API only applies the outstanding changes. It doesn’t force the generation of Files or DialPlan to avoid overloading the system.

For modules, you have to alter the table “ombu_queued_changes” and for DialPlan the “ombu_settings,” specifically the “reload_dialplan” parameter; this parameter must have the auto-generated tenant prefix when using sub-tenants “T2_reload_dialplan.”

It does the same that the GUI, and it follows the same rules.

This was working fine till i guess the latest version(s). We are in need of a solution how to trigger this again via the API. Can you please help us? Thanks.

For example: let us send data via the request like “reload-all: yes” so really all changes will be applied like before.

What i can see in ombu_settings table:

  • vitalpbx reload no
  • dahdi_hardware reload no
  • firewall reload no
  • intrusion_detection reload yes (why would this default to yes)?
  • core reload_dialplan no

Could there be more or is that all?

API could handle each of those.

Thanks

The Intrusion Detection module doesn’t exist anymore, so this parameter does nothing.

About the ombu_settings, the “reload_dialplan” is the parameter that you need if you want to reload the PBX DialPlan. In the case of the vitalpbx-reload, it is just to show the reload circle in the GUI. The others apply the reload to the respective modules.

Could you please add the possibility to set the “reload_dialplan” to yes via API so we have this working again? This is important to us since this was working before but now not anymore.
If you make it optional it is fine for us. But we need it.