ICE Host Settings with DDNS

Dears ,
In our case the system is published through one-to-one NAT and working fine ,but the issue is the public ip is not static it dynamically allocated ,

is their any workaround to update the advertised address by fqdn not ip address

Thanks

1 Like

Hello,

Currently, we have not tested a scenario involving one-to-one NAT with a dynamic IP updated via Dynamic DNS. Based on Asterisk documentation, it may work by configuring the External media address and External signal address (you can find these settings under Settings/Technology Settings/PJSIP Settings) with your Dynamic DNS hostname.

Currently, the VitalPBX interface does not support enabling the “DNS Manager” module. Therefore, you should try creating the “dnsmgr.conf” file in /etc/asterisk/

Here’s a sample dnsmgr.conf configuration:

[general]
enable=yes       ; Enable the DNS manager
refreshinterval=300 ; Time in seconds between DNS lookups

Afterward, restart Asterisk.

While we have not personally tested this specific setup, please make sure to back up before making any changes.

Best regards,

Unfortuntly no audio on calls with this way ,
only the audio comes out when the public ip in advertising address

but after unfurtntly the ip is updated we need to update it manual

Have you tried setting the DDNS on the “Advertising address”?

When saving the address disapperd, not saving

Type the address and hit Enter on the keyboard.
Hit save.