How to configure VitalPBX Connect app

I downloaded VitalPBX Connect iOS mobile app from App Store and tried to scan the bar-code of an extension on VitalPBX version 4.0.0-3 but it gave an error. Any suggestion how to program this new mobile app?

Thank you.

You need to update to the latest VitalPBX version and download/install the Connect add-on from the add-ons module.

Can you please tell more about the VitalPBX Connect app?

You developed it?
What is the base of it?
BLF possible?
Rebranding possible?
License needed? Which one?

Thanks a lot and Happy New Year.

1 Like

I have latest version 4.0.0-8 and Add-on Connect version 4.0.0-4. When I scan the bar-code i get an errors " error downloading external provisioning".

I have entered the server’s FDQN name in the settings of the VitalPBX Connect module. Also, we are using the same SSL certificate as for all or our licensed V3 servers.

I don;t see any errors in the firewall logs either. The only other thing is I don’t know which file and from which folder it’s trying to download and that file and folder have proper permissions set.

We had issues with our data center those days, so I recommend you try again!

I still get “user not found” error when scanning the bar-code
I have enabled “Ring Device” and “Mobile Client” in the extension page (but not WebRTC).

Both, the “Provisioning Domain IP” and “Registration Domain IP” are the FDQN of the server name. In the devices page under “VitalPBX Connect”, I can see the device that is enabled. Is there any other configuration to be tweaked? Please advise. Than you.

Delete the user or disable the setting, then re-add o re-enable the mobile option.

Thank you Miguel! That worked well!

Now I’m trying to set up our own provisioning server. The Connect app points to

I have set up the server with respective directories and a databases to hold the credentials for each user account. What shall I put inside account?

Please advise. Thank you!

HI, I followed the instructions given in the article, but by scanning the QR code, the smartphone does not connect and the following message appears " cUrl error 28: Connection timed out for http://ip_vitalpbx:3500/api/v2/vpbx-connect/account?username=xxxxx&password=xxxxxx. What am I doing wrong?
Thank you

Possible Reasons:

  • The firewall is blocking the request
  • The IP isn’t public

Hello Miguel,
Connect works only with public IP, can I use a private ip of my lan?

Thank you


To provision the app, you need a public IP.

On the other hand, if you see closer in the Connect Settings, you will see two fields:

  • Provisioning Domain / IP
  • Registration Domain / IP

The first one is for provisioning and must be public, and the second one is to register the application and could be private.

Nonetheless, when using private IP for registration, there’s a chance that the push notifications do not work.

Hello Miguel,

I configured the public IP and now works fine.

Thank you.


We have the same problem as mentioned above by @TELESPEX - “error downloading external provisioning” but this is only for one user … everyone else is fine. We have uninstalled, deleted the user and recreated them, etc etc … always the same error. Suggestion(s)?

I have the same problem because I have opened only the needed ports on my Hypervisor, so the Hypervisor blocks the provisioning request, could you tell me the provisioning port to open it?

Thank you.

Hi Miguel, I have an issue when download VitalPBX Connect add-on, after this when I access to the PBX the following message is showed:

Fatal error : Uncaught Error: Call to undefined method modules\core\APPLicense::hasOnePlan() in /usr/share/vitalpbx/www/includes/addons/vitalpbx_connect.php:0 Stack trace: #0 /usr/share/vitalpbx/www/modules/mobile_settings/mobile_settings.php(0): vitalpbx\addons\vitalpbx_connect->getAllowedItems() #1 /usr/share/vitalpbx/www/includes/app/Core.php(0): modules\mobile_settings\mobile_settings->getContent() #2 /usr/share/vitalpbx/www/includes/app/Core.php(0): app\Core->loadModuleAction() #3 /usr/share/vitalpbx/www/includes/app/Core.php(0): app\Core->_loadModule() #4 /usr/share/vitalpbx/www/includes/app/Core.php(0): unknown() #5 /usr/share/vitalpbx/www/index.php(0): app\Core->run() #6 {main} thrown in /usr/share/vitalpbx/www/includes/addons/vitalpbx_connect.php on line 0

Maybe you saw this issue before.
Thank you.

You must update the whole PBX.

apt clean all
apt update
apt upgrade -y

Thank you very much Miguel!!

1 Like