Help in DIDWW Trunk

Hello iam new to VitalPBX , i wont to receive my did number from DIDWW to vitalPBX , what is the setting shoud i add in VitalPBX Trunk … this link contain DIDWW trunk setting for Incoming .

How can i add these setting in VitalPBX …

Create a PJSIP Trunk, add all IPs to the Match/Permit field.

1 Like


Good evening… So, like PitzKey said, you need to create a trunk… Look at the image I posted… Under “Remote Host,” Type in the IP address as given by DDWW. Also, on “Match,” type in the IP address where the origination (inbound) is going to send DID traffic from.

To create the trunk: go to PBX, External, Trunks.

You also need to whitelist the IP address that DIDWW is sending traffic to the PBX from… Goto Admin, Firewall, Settings, Whitelist, and enter the IP address that needs to be white listed.

I also don’t know if you have a static IP listed with DIDWW or if you will need to enter credentials for registration. If so, on the “Trunks,” you will need to set the “Require Registration” to yes and put the information for the user name and password in the required sections.

1 Like

No Succes , i tryed everything . can you send me your e-mail i will give accest to you to my test server .

Please share a debug log via

1 Like

From this logs it looks like they successfully send a call to DID 972559397725, but it seems like no inbound route is configured for this DID.

1 Like

there is inbound route see the image

You must remove the CID Pattern value. configuring that parameter means you want to match the Incoming Caller ID Number.

1 Like

Sorry I missed your message. It’s been a busier week. You make any progress on this?

1 Like

it Works , it Rings now i remove the CID pattern value , Now i have new Problem No voice after answering the call , no voice at two ways any idea ??

No audio is usually a NAT issue. Are you behind a firewall?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.