Grandstream GXP 2160 BLF keys, Night Mode,

Gents, Ladies (if there are any in this Forum world),

I have a client who wants a BLF Key to show “Night Mode” Status/Toggle.

I created the Night mode in VitalPBX (EASY), but when I goto the phone and I add a BLF key and then I add the code (I have tried a few ways, maybe I am inputting it wrong) 900, or 900, or #900 it doesn’t light up nor does it work. The “Programmable Button” has several “Modes” that I can select, I have tried a few but mainly testing with BLF.
Now in the demo video it was shown with putting a "
" in front of the number for the “code”. I don’t find that working, but if I just enter a number and then dial #900 the phone tells me the night mode is enabled/disabled.

Can anyone shed some light on my error?

Thanks in advanced,

Jeff

Did you enable the option “Generate Hint” on your Night mode?

The solution is easy:
Don’t use the number of the night mode. Use the hint.
NM_1 for example. And yes, you need set to generate hint to yes first.

Would have been a lot easier to not have extra hints but being able to use the number for blf.

Thank you, it worked,
I did what you said and only put the “Hint” into the field where I would have put the Code.

It would have been nice if the documentation would have made that a little more clear.

Thanks again for the help.

Jeff