Expired SSL locking out

I’m completely locked out of the GUI due to an SSL issue.

Running Debian 11 on Vultr

This applies:

But, running reset-apache-conf didn’t resolve. In the apache error log:

Any ideas? Is there a way for me to revert to non SSL access temporarily via command line so I can log in and get a new cert? or a way for me to install a new cert via command?

Using the command vitalpbx reset-apache-conf will reset the SSL configurations and disable the option that forces secure connections.

After executing the command, you must try accessing via HTTP(port 80) using an incognito tab. Keep in mind that you might need to allow port 80 on any additional firewall in front of VitalPBX.

P.D.: When using Let’s Encrypt, you must always allow port 80 and the incoming connections from the USA. This will allow renewing the Let’s Encrypt certs automatically!

1 Like